Bug 56306 - warning MSB3026 Could not copy "obj\Debug\xxxxx.dll" to "bin\Debug\xxxxx.dll". Beginning retry 1 in 1000ms. The process cannot access the file 'bin\Debug\xxxxx.dll' because it is being used by another process
Summary: warning MSB3026 Could not copy "obj\Debug\xxxxx.dll" to "bin\Debug\xxxxx.dll"...
Status: RESOLVED DUPLICATE of bug 56275
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-12 17:29 UTC by John Miller [MSFT]
Modified: 2017-05-29 14:29 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
xf logs last 7 days (11.16 KB, application/x-zip-compressed)
2017-05-12 20:15 UTC, DmytroBondarenko
Details
xf logs all (11.39 KB, application/x-zip-compressed)
2017-05-12 20:15 UTC, DmytroBondarenko
Details
vs info (3.63 KB, text/plain)
2017-05-12 20:17 UTC, DmytroBondarenko
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56275

Description John Miller [MSFT] 2017-05-12 17:29:02 UTC
## Overview

Users are reporting issues after updating to the latest 15.2 tooling. Specifically, an error similar to this when building:

> warning MSB3026 Could not copy "obj\Debug\xxxxx.dll" to "bin\Debug\xxxxx.dll". Beginning retry 1 in 1000ms. The process cannot access the file 'bin\Debug\xxxxx.dll' because it is being used by another process

This seems similar to https://bugzilla.xamarin.com/show_bug.cgi?id=31423. 

I've not been able to reliably reproduce this yet. 

## Additional Information

There are reports from these forum posts:
https://forums.xamarin.com/discussion/comment/273033
https://forums.xamarin.com/discussion/95238/
Comment 1 DmytroBondarenko 2017-05-12 20:15:07 UTC
Created attachment 22143 [details]
xf logs last 7 days
Comment 2 DmytroBondarenko 2017-05-12 20:15:52 UTC
Created attachment 22144 [details]
xf logs all
Comment 3 DmytroBondarenko 2017-05-12 20:17:16 UTC
Created attachment 22145 [details]
vs info
Comment 4 DmytroBondarenko 2017-05-12 20:21:47 UTC
Hello! 
Here are my logs - from the XF (last 7 days and all) and the VS info. 
Unfortunately I can't provide the project with bug at this moment.
I'm working on the sample project and I will provide it ASAP.
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2017-05-12 22:26:09 UTC

*** This bug has been marked as a duplicate of bug 56275 ***
Comment 6 Zahi Kramer 2017-05-16 10:15:50 UTC Comment hidden (obsolete)
Comment 7 Matthew Richardson 2017-05-29 14:29:21 UTC Comment hidden (obsolete)