Bug 56259 - Xamarin Live Player - IOS - Visualization Error - Exception of type 'Foundation.ModelNotImplementedException' was thrown
Summary: Xamarin Live Player - IOS - Visualization Error - Exception of type 'Foundati...
Status: RESOLVED FIXED
Alias: None
Product: Live Player
Classification: Xamarin
Component: Mobile App iOS (show other bugs)
Version: 1.0.253
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-12 04:40 UTC by hugo.m.o
Modified: 2017-10-13 21:16 UTC (History)
21 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Device is already paired but the execution failed (16.96 KB, image/jpeg)
2017-05-12 04:40 UTC, hugo.m.o
Details
References for PCL (11.46 KB, image/png)
2017-05-12 13:02 UTC, Yak Shaver
Details

Description hugo.m.o 2017-05-12 04:40:55 UTC
Created attachment 22102 [details]
Device is already paired but the execution failed

Device is already paired but the execution failed with the message "Visualization Error - Exception of type 'Foundation.ModelNotImplementedException' was thrown."
Comment 1 Ravinder Jangra 2017-05-12 08:29:22 UTC
not generating any log into system. where can we find brief logs. Facing sane issue as mentioned above.
Comment 2 Yak Shaver 2017-05-12 13:02:06 UTC
Created attachment 22125 [details]
References for PCL

Same problem here. Attached are the referenced libraries for the PCL. I'm using MVVM with very little code in my code-behind files.
Comment 3 Scott Spiller 2017-05-12 15:51:58 UTC
Same issue here.  Not sure what's causing it.  Using xamarin forms PCL.  Unique code to iOS is a custom renderer to overload the timepicker.  Also watching for notifications in appdelegate.  UNUserNotificationCenter.Current.Delegate = new UserNotificationCenterDelegate();
Comment 4 Utsav 2017-05-12 16:29:33 UTC
ColorContrast example from xamrin sample code works fine of Live player for iphone.
But if I compile and use blank "Hello world" test app, it throws "Visualization Error" on the iphone device.
Comment 5 Ado 2017-05-12 20:25:35 UTC
Same issue here
Comment 6 Greg 2017-05-12 23:52:13 UTC
Getting this issue in BasicCalculator example
Comment 7 Carsten 2017-05-13 00:40:09 UTC
Same issue here.
Created a brand new Xamarin forms PCL project (Welcome to Xamarin Forms).
Using an iPhone 5s with iOS 10.3
Comment 8 david 2017-05-13 03:51:46 UTC
Live player doesn't work at all on my setup.

VS for Mac 7.1 Preview (7.1 b582) = absolutely latest bits downloaded yesterday.

Installed Live Player app on both Android and iOS devices. App loads and connects (though throws some exceptions sometimes when connecting).

Green text on app indicates successful connection to VS, but there's no menu item to select the device as a Player in the device dropdown. Also under the Run menu, we have an item "Live Run Current View" but it's greyed out and can't be selected.
Comment 9 James Montemagno [MSFT] 2017-05-13 03:55:22 UTC
So, try it with a shared project currently. The build that was submitted to apple for a approval is a week old and we caught this one right after it was submitted so a new one is coming down extremely soon.
Comment 10 david 2017-05-15 01:37:14 UTC
@James M The "app" I was referring to was created brand-new with the latest VS Mac. The default project types give only Shared Project for a cross-platform app (something I'm a bit unhappy about) so I was already working with a Shared Project app.
Comment 11 alan.grgic 2017-05-15 05:25:13 UTC
I have a version of the app that was released earlier today (according to the App Store history), and it is exhibiting the problem James is describing (shared projects work but PCLs don't).

At first I was seeing this error on both types of projects, but uninstalling and reinstalling the live player app made it work on shared projects only. I'm a little confused because James' comment made it sound like a fix was coming that would resolve this for PCLs, but the update I just got looks like it enabled it to work only on shared projects?

In any case, if you installed the live player app before 5/14, you could try getting the update -- shared projects were not working for me either until I got it.
Comment 12 Redar 2017-05-16 17:29:07 UTC
The sample app is working perfectly, but my PCL app is giving an Error. I removed the app on my iPhone and re-downloaded still an Error. I think, they have not fixed PCL support for Live Player.
Comment 13 Daniel 2017-05-21 08:24:53 UTC
I've got this too. Visual Studio 2017 Preview 15.3 on Windows 10. iPhone 5S, iOS 10.2.1.

New Project > Visual C# > Cross Platform App > Blank App

Selected Xamarin Forms and PCL.

Build and then Run on Live Player = Foundation.ModelNotImplementedException (thrown on iPhone)

Shared project works fine as James says.
Comment 14 James Montemagno [MSFT] 2017-05-30 18:07:53 UTC
The current iOS build supported Shared projects, and the next version has the fix for PCL projects.
Comment 15 longlostbro 2017-06-09 20:24:24 UTC
When will the version containing this fix be released?
Comment 16 phiwengq 2017-09-03 19:29:22 UTC
Hi James

When is the next app coming out, or how do I restore Xamarin live to work on shared projects?
Comment 17 phiwengq 2017-09-03 19:46:57 UTC
Alright, created new app as shared project and copied source from previous shared project. Working again in Xamarin live.
Comment 18 Markus 2017-10-13 21:16:18 UTC
Is there a new Version? Visual Studio 15.4 ist released and I still get this error with PCL. Shared is working. But all my exisiting Xamarin Projects use PCL...

Note You need to log in before you can comment on or make changes to this bug.