Bug 56232 - [VS][15.2] Android and iOS inspection broken
Summary: [VS][15.2] Android and iOS inspection broken
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Inspector Integration (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
URL:
: 56284 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-05-11 16:21 UTC by Sandy Armstrong [MSFT]
Modified: 2017-09-08 16:48 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Ide logs (6.09 MB, application/x-zip-compressed)
2017-05-16 06:40 UTC, Alok Kulkarni
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Sandy Armstrong [MSFT] 2017-05-11 16:21:18 UTC
VS2017 15.2
XVS 4.5.0.443
Inspector 1.2.2 (doesn't matter what version is installed, as long as it's installed)

1. Open a Xamarin.Android or Xamarin.iOS project.
2. F5 to begin debugging.

Expected result:

App launches, inspect button enables, can click to open Inspector.

Actual results:

App launches, inspect button remains disabled. The following error is logged:

InspectorDebugSession(0): AgentBridge.InjectAssembly: System.MissingMethodException: Method not found: 'Mono.Debugger.Soft.Value Mono.Debugger.Soft.TypeMirror.InvokeMethod(Mono.Debugger.Soft.ThreadMirror, Mono.Debugger.Soft.MethodMirror, System.Collections.Generic.IList`1<Mono.Debugger.Soft.Value>)'.
   at Xamarin.Interactive.IdeSupport.AgentBridge.InjectAssembly(String agentAssemblyPath)
   at Xamarin.Interactive.IdeSupport.InspectorDebuggerSession.<HandleTargetEvent>b__26_0(Object <p0>) in C:\d\lanes\4699\c8715752\source\xamarinvs\External\inspector-ide-integration\Xamarin.Interactive.IdeSupport\InspectorDebuggerSession.cs:line 242
InspectorDebugSession(0): StateChange: EntryPointBreakpointHit -> Error

This indicates that the Inspector extension (shipped with XVS, not the Inspector client) references the wrong version of Mono debugger assemblies, compared to what the rest of XVS ships.
Comment 5 Luis Aguilera 2017-05-12 13:43:24 UTC
*** Bug 56284 has been marked as a duplicate of this bug. ***
Comment 6 Alok Kulkarni 2017-05-16 06:39:37 UTC
## Verified on build info : https://gist.github.com/alok-kulkarni/3685797c253b8fdee4c61f2c8c9fa83e

## Environment : 
Tested on : 
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01590
Installed Version: Enterprise
Xamarin 4.5.0.455 (3c254b0)
Xamarin.Android 7.3.0.13 (448f54f)
Xamarin.iOS 10.10.0.30 (30b6e87)
Xamarin Workbook : Verison 1.2.2(d15.1-b71b035)

## Screencast  for Android  : https://www.screencast.com/t/W2c7vYwLV

## For iOS : https://www.screencast.com/t/lMGDrqEV5TF

## Logs Attached 

@ Sandy kindly mark it as resolved so that I can mark it as Verified.
Comment 7 Alok Kulkarni 2017-05-16 06:40:01 UTC
Created attachment 22185 [details]
Ide logs