Bug 56132 - Multithreaded AppDomain loading crashes runtime
Summary: Multithreaded AppDomain loading crashes runtime
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-09 11:23 UTC by David Karlaš
Modified: 2017-05-19 23:06 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 56132 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description David Karlaš 2017-05-09 11:23:47 UTC
Here is link to crash: https://gist.github.com/DavidKarlas/fd61dc1dd458ddb86a2bdd2fd1a1129a
And link to modified mono with unit test that crashes runtime: https://github.com/mono/mono/tree/crashMultithreadDomains
Comment 1 Zoltan Varga 2017-05-19 23:06:58 UTC
I can repro this with master.