Bug 56008 - Intellisense triggering on comment in iOS UIViewController
Summary: Intellisense triggering on comment in iOS UIViewController
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 7.0 (VSforMac)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2017-05-04 22:21 UTC by Kent Green [MSFT]
Modified: 2017-10-05 15:32 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
reproduction sample & IDE logs (247.23 KB, application/zip)
2017-05-04 22:21 UTC, Kent Green [MSFT]
Details

Description Kent Green [MSFT] 2017-05-04 22:21:53 UTC
Created attachment 21962 [details]
reproduction sample & IDE logs

## Overview
Intellisense is recommending the inclusion of a partial void method while I'm writing a comment; requiring me to repeatedly cancel it or else it injects the partial void class into my comment line. 

Part of this behavior is "correct", because the partial void method it is recommending would be valid based on the associated storyboard file. However, it is "incorrect" because it is triggering while I am in a comment line; no other intellisense suggestions seem to be triggering here. 

## Code snippet
> // Intellisense sees the partial void class below is missing because I commented it out, so it tries to inject it while I'm writing this comment
> // partial void ButtonAbout_TouchUpInside (UIButton sender)
> // {		
> // }

## Steps to reproduce the problem
1. Open "ViewController.cs"
2. Comment out the "ButtonAbout_TouchUpInside" method 
3. Within the ViewController class, create a new comment line and type a message, you should see Intellisense try to auto-suggest injecting the "ButtonAbout_TouchUpInside" method into the comment.

## Expected Results
Intellisense should include the partial void method as a suggestion only when outside of comment lines; as it does for most other suggestions.

## How often does this happen?
I have not seen this occur for other types of methods, so it may be an isolated occurrence; but I do not know for certain how to test this extensively, since Intellisense triggering on comments seems like a very unusual behavior.  

## Build information
=== Xamarin Studio Community ===

Version 6.3 (build 864)
Installation UUID: 8ef63a7c-1b18-40de-a334-7f78777fcb55
Runtime:
	Mono 5.0.0.94 (2017-02/1d0445b) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 500000094

=== NuGet ===

Version: 3.5.0.0

=== Xamarin.Profiler ===

Version: 1.5.4
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 8.3.2 (12175)
Build 8E2002

=== Xamarin.iOS ===

Version: 10.10.0.30 (Xamarin Studio Community)
Hash: 30b6e87e
Branch: d15-2
Build date: 2017-04-28 17:17:13-0400

=== Xamarin.Android ===

Version: 7.3.0.13 (Xamarin Studio Community)
Android SDK: /Users/kentgreen/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)
		7.1    (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin.Mac ===

Version: 3.4.0.30 (Xamarin Studio Community)

=== Xamarin Inspector ===

Version: 1.2.2
Hash: b71b035
Branch: d15-1
Build date: Fri, 21 Apr 2017 17:57:12 GMT

=== Build Information ===

Release ID: 603000864
Git revision: 6c2f6737278ccc3e81e12276d49c0d92f975f189
Build date: 2017-04-24 11:26:01-04
Xamarin addins: d8d46e577d8507c35260ce9d73df3c33415bb214
Build lane: monodevelop-lion-d15-1

=== Operating System ===

Mac OS X 10.12.4
Darwin Kents-MBP.guest.corp.microsoft.com 16.5.0 Darwin Kernel Version 16.5.0
    Fri Mar  3 16:52:33 PST 2017
    root:xnu-3789.51.2~3/RELEASE_X86_64 x86_64
Comment 1 Jeffrey Stedfast 2017-05-05 14:41:38 UTC
Yep, can confirm with VS4Mac 7.0 preview 9
Comment 2 Mike Krüger 2017-09-26 08:09:00 UTC
Can't reproduce it in newer versions.

Note You need to log in before you can comment on or make changes to this bug.