Bug 55932 - FullAOT lanes fail "verify" step on every build
Summary: FullAOT lanes fail "verify" step on every build
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-05-03 20:05 UTC by Andi McClure
Modified: 2017-07-19 16:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 55932 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Andi McClure 2017-05-03 20:05:26 UTC
If you look at our FullAOT lanes

https://jenkins.mono-project.com/view/All/job/jenkins-testresult-viewer/Test_Result_View/builds-plus.html#LinuxARM32el=Hide&LinuxARM32elFullAOT=Show&LinuxARM32elPR=Hide&LinuxARM32hf=Hide&LinuxARM32hfFullAOT=Show&LinuxARM32hfPR=Hide&LinuxARM64=Hide&LinuxARM64FullAOT=Show&LinuxARM64PR=Hide&LinuxIntel32=Hide&LinuxIntel32Coop=Hide&LinuxIntel32FullAOT=Show&LinuxIntel32PR=Hide&LinuxIntel64=Hide&LinuxIntel64Bitcode=Hide&LinuxIntel64BitcodeValgrind=Hide&LinuxIntel64Checked=Hide&LinuxIntel64Coop=Hide&LinuxIntel64FullAOT=Show&LinuxIntel64FullAOTPR=Show&LinuxIntel64HybridAOT=Hide&LinuxIntel64MCS=Hide&LinuxIntel64MCSPR=Hide&LinuxIntel64PR=Hide&MacIntel32=Hide&MacIntel32PR=Hide&MacIntel64=Hide&MacIntel64PR=Hide&WindowsIntel32=Hide&WindowsIntel32PR=Hide&WindowsIntel64=Hide&WindowsIntel64PR=Hide&groupBy=Builds&span=Last7Days

Every single lane fails on the make -w -C runtime mcs-compileall ("verify" / "`Compile all assemblies with the verifier turned on. Code must be valid but not verifiable.`") step. An example

https://jenkins.mono-project.com/job/test-mono-mainline-fullaot/label=ubuntu-1404-amd64/298/parsed_console/log_content.html#WARNING2

Failures go on for pages and look like

Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:get_Test () failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:get_Test (): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:get_Context () failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:get_Context (): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:get_Result () failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:get_Result (): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:Execute (NUnit.Framework.Internal.TestExecutionContext) failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:Execute (NUnit.Framework.Internal.TestExecutionContext): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:RunTestWithTimeout (int) failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:RunTestWithTimeout (int): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:RunTest () failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:RunTest (): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.WorkItems.WorkItem:WorkItemComplete () failed with exception 'Error verifying NUnit.Framework.Internal.WorkItems.WorkItem:WorkItemComplete (): Could not load type NUnit.Framework.Internal.WorkItems.WorkItem at 0x0000':
Compilation of NUnit.Framework.Internal.Commands.ExpectedExceptionCommand:IsExpectedMessageMatch (System.Exception) failed with exception 'Error verifying NUnit.Framework.Internal.Commands.ExpectedExceptionCommand:IsExpectedMessageMatch (System.Exception): Cannot load method from token 0x0a0001c0 for call at 0x0076':
Compilation of NUnit.Framework.Internal.Commands.MaxTimeCommand:Execute (NUnit.Framework.Internal.TestExecutionContext) failed with exception 'Error verifying NUnit.Framework.Internal.Commands.MaxTimeCommand:Execute (NUnit.Framework.Internal.TestExecutionContext): Cannot load method from token 0x0a000195 for call at 0x0000':

We are currently unable to build the BCL with MCS ( https://bugzilla.xamarin.com/show_bug.cgi?id=55929 ) but I don't know if the verifier actually relies on MCS so I don't know if that's relevant.