Bug 55720 - [VS SDK Manager] On uninstalling Latest build of SDK Tools, All SDK tools are uninstalled
Summary: [VS SDK Manager] On uninstalling Latest build of SDK Tools, All SDK tools are...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: SDK Manager (show other bugs)
Version: 7.3 (15.2)
Hardware: PC All
: High critical
Target Milestone: 15.3
Assignee: Vsevolod Kukol
URL:
Depends on: 56021
Blocks:
  Show dependency tree
 
Reported: 2017-04-28 11:54 UTC by Mohak Barokar
Modified: 2017-05-16 08:06 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments
SDK Mananager generated Logs (23.28 KB, application/x-zip-compressed)
2017-04-28 11:54 UTC, Mohak Barokar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mohak Barokar 2017-04-28 11:54:23 UTC
Created attachment 21874 [details]
SDK Mananager generated Logs

On Uninstalling Android SDK Tools version 26.0.1 from Tools pane Previous installed Version i.e. 25.2.5 is also getting uninstalled when SDK Manager is reopened

====================================================================================

Environment Info:
 -Microsoft Visual Studio Professional 2013 Version 12.0.40629.00 Update 5
 -Microsoft .NET Framework Version 4.6.01590
 -Xamarin   4.5.0.437 (4cffdce)
 -Xamarin.Android   7.3.0.13 (448f54f)
 -Xamarin.iOS   10.10.0.26 (5ac8af1)

 Platform : Windows 7
 
 Detailed Build Info : https://gist.github.com/mohakbarokar/c520a665656fdbd2edb1c5caf905711a

====================================================================================

Steps:
1. Launch SDK Manager
2. Navigate to Tools Pane
3. Uncheck Android SDK Tools v. 26.0.1 and Apply Changes.
4. Wait Till component is uninstalled
5. Restart SDK Manager
6. Navigate to Tools Pane and Observe Installed SDK Tools

====================================================================================

Expected Result: 
The SDK Tools version which are selected by user should only get uninstalled.

Actual Result : 
All SDK Tools versions are getting Uninstalled

====================================================================================

Reproducibility: 100%

====================================================================================

Screencast Link: http://www.screencast.com/t/qtsaqecw

====================================================================================

SDK Manager Logs Attached.
Comment 2 Vsevolod Kukol 2017-05-10 06:25:06 UTC
Fixed in version 7.1.0.580 (d15-3-preview)

Author: Vsevolod Kukol
Commit: 78ac3a2f49fb441da608a5110db5a7f99472b0af (xamarin/android-sdk-installer)
Included in Commit: 005c21dbce9476a6c3f353591cc3a3a627edd43a (mono/monodevelop)
Comment 3 Mohanish Patil 2017-05-12 12:50:37 UTC
Hello @Vsevolod Kukol 

Target milestone for this defect need to get change to 15.3 since its not been released on 15.2 build.
Comment 4 Gaurav Ganorkar 2017-05-16 08:06:38 UTC
Verified this issue on the build
https://bosstoragemirror.blob.core.windows.net/wrench/sdk-manager-windows-master/1c/1c4ba1d8eb6cd971b78a49981c4761ad0e800afb/Xamarin.AndroidSDKManager.msi

No checkbox is displayed now.Radio buttons have been added which fixed the issue.

We have observed some irregular installation failure which have been covered on the bug https://bugzilla.xamarin.com/show_bug.cgi?id=56269