Bug 55673 - Can't debug iOS project. Error checking consistency between local and remote
Summary: Can't debug iOS project. Error checking consistency between local and remote
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA (show other bugs)
Version: 4.4.0 (15.1)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-27 08:28 UTC by Tomasz Cielecki
Modified: 2017-10-01 21:09 UTC (History)
8 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Tomasz Cielecki 2017-04-27 08:28:13 UTC
When attempting to debug either for iPhoneSimulator or iPhone the Debug output window in VS2017 shows the following exception:

[Inspector] Error preparing project for inspection: System.NotImplementedException: Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))
   at EnvDTE.Project.get_FullName()
   at Xamarin.VisualStudio.Inspector.VSAgentExecutionTarget..ctor(Project proj) in C:\d\lanes\4471\3f99c5a7\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSAgentExecutionTarget.cs:line 36
   at Xamarin.VisualStudio.Inspector.VSInspectorSession.CreateAgentExecutionTarget() in C:\d\lanes\4471\3f99c5a7\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSInspectorSession.cs:line 84
   at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare() in C:\d\lanes\4471\3f99c5a7\source\xamarinvs\External\inspector-ide-integration\Xamarin.Interactive.IdeSupport\InspectorSession.cs:line 95
   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\d\lanes\4471\3f99c5a7\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 136
An unexpected error occurred while checking consistency between the local app and the remote build for SurveyApp.iOS. Please rebuild the application and try again. Check the logs for more details

I've tried enabling and disabling profiler in project settings, no difference.

Both VS2017 and XS are latest stable.

VS2017 15.1 (26403.7)
Xamarin 4.4.0.34 (3f99c5a)
Xamarin.iOS 10.8.0.174 (7656cc6)
Xamarin Inspector 1.2.2

Xamarin Studio 6.3 (build 863)
Mono 4.8.1

Not sure if this is a dupe of: https://bugzilla.xamarin.com/show_bug.cgi?id=54329
Comment 1 Tomasz Cielecki 2017-04-27 08:34:46 UTC
After removing Workbooks through the VS2017 installer that exception above doesn't show anymore. However, the error with consistency checking persists. Even if I do as it suggests. I've also tried removing the mtbs cache on the mac itself.
Comment 2 Jose Gallardo 2017-05-18 14:12:52 UTC
Hi Tomasz,

This is odd, we'll investigate. In the meantime, I can give you a suggestions that might help and a quick question:

1. Can you try deleting output folders from both sides Windows (bin+obj folders) and Mac (mtbs cache)?

2. Does the same issue happen on a new iOS app from scratch?

Thanks
Comment 3 mag@xamarin.com 2017-07-05 02:52:34 UTC
Hi,
Do you have any extra information or update about this problem?
Thanks
Comment 4 mag@xamarin.com 2017-07-05 19:44:14 UTC
This should be fixed for the upcoming 15.4 release, since we have been making improvements and fixes around build inconsistency checks between local and remote builds.
For this reason and given that we didn't receive much more information about the issue, I'm considering it as Resolved.

Note You need to log in before you can comment on or make changes to this bug.