Bug 55588 - Cannot open more than one ContextAction in different ListViews on IOS
Summary: Cannot open more than one ContextAction in different ListViews on IOS
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Chris King
URL:
: 55607 57066 57128 57273 59445 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-25 19:55 UTC by roberto.can
Modified: 2017-09-20 11:32 UTC (History)
11 users (show)

Tags: ios listview contextaction cell
Is this bug a regression?: Yes
Last known good build: 2.3.3.193


Attachments
A sample app with two listviews and context actions in both (73.09 KB, application/x-rar)
2017-04-25 19:55 UTC, roberto.can
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description roberto.can 2017-04-25 19:55:08 UTC
Created attachment 21777 [details]
A sample app with two listviews and context actions in both

I have a Xamarin Forms application with a simple TabbedPage, with two tabs (see the attachment).
Inside both tabs, I have a ListView with a ContextAction that has a simple MenuItem.
When the ContextAction MenuItem is opened in the tab one, I cannot open the second one inside any other tab. Its is a simple example, but I have a big application with a lot of ListViews.

Until the version 2.3.3.193, I didn't get this bug.
I tested the application's source with almost all the last pre-releases after  2.3.3.193 and it occurs with all versions (up to 2.3.5.X).
Comment 1 Jimmy [MSFT] 2017-04-26 15:10:53 UTC
I am able to reproduce this issue with the attached project. This appears to be a regression in 2.3.4.


### Steps to Reproduce
1. Run the attached iOS project
2. Open the ContextActions of one the list items
3. Go to the "Browse 2" tab
4. Attempt to the open the ContextActions on a list item


### Regression Test
2.3.6.87    BAD
2.3.5-pre1  BAD
2.3.4.231   BAD
2.3.3.193   GOOD
Comment 2 Jimmy [MSFT] 2017-04-26 15:11:20 UTC
*** Bug 55607 has been marked as a duplicate of this bug. ***
Comment 3 Matthias 2017-04-26 16:59:15 UTC
Sorry, it seems I didn't search well enough for duplicates...

I made a fix and made a PR with it here: https://github.com/xamarin/Xamarin.Forms/pull/885
Comment 4 Chris King 2017-04-26 17:22:29 UTC
Will confirm fix...
Comment 6 Samantha Houts [MSFT] 2017-04-27 19:40:09 UTC
Should be fixed in 2.3.5 stable. Thank you!
Comment 7 Jimmy [MSFT] 2017-06-01 21:39:40 UTC
*** Bug 57066 has been marked as a duplicate of this bug. ***
Comment 8 Paul DiPietro [MSFT] 2017-06-04 17:31:43 UTC
*** Bug 57128 has been marked as a duplicate of this bug. ***
Comment 9 Jimmy [MSFT] 2017-06-08 14:47:12 UTC
*** Bug 57273 has been marked as a duplicate of this bug. ***
Comment 10 Samantha Houts [MSFT] 2017-06-08 17:55:39 UTC
(In reply to Samantha Houts from comment #6)
> Should be fixed in 2.3.5 stable. Thank you!

Correction! Should be fixed in 2.3.6-pre1.
Comment 11 Samantha Houts [MSFT] 2017-06-22 17:57:01 UTC
(In reply to Samantha Houts from comment #10)
> (In reply to Samantha Houts from comment #6)
> > Should be fixed in 2.3.5 stable. Thank you!
> 
> Correction! Should be fixed in 2.3.6-pre1.


Nope, right the first time. Should be fixed in 2.3.5 stable. Thank you!
Comment 12 Gaurav Ganorkar 2017-06-29 12:57:42 UTC
Verified this defect on  Xamarin forms version 2.3.5.255-pre5
We can now  open more than one ContextAction in different ListViews on IOS.

Verified on the build 
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise


Xamarin   4.6.0.279 (de55d19)

Xamarin.Android   7.4.0.13 (f6289cd)

Xamarin.iOS   10.12.0.12 (494fcbc)

Forms.Version 2.3.5.255-pre5
Comment 13 Paul DiPietro [MSFT] 2017-09-13 14:04:59 UTC
*** Bug 59445 has been marked as a duplicate of this bug. ***