Bug 55558 - Navigation bar back button with keyboard white space in adjust mode Resize
Summary: Navigation bar back button with keyboard white space in adjust mode Resize
Status: RESOLVED DUPLICATE of bug 45215
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.4
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-04-25 13:31 UTC by Diego
Modified: 2017-05-23 18:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test project to reproduce the error (139.05 KB, application/zip)
2017-04-25 13:31 UTC, Diego
Details
Error Image (18.35 KB, image/png)
2017-04-25 13:31 UTC, Diego
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 45215

Description Diego 2017-04-25 13:31:15 UTC
Created attachment 21756 [details]
Test project to reproduce the error

When the Android app is set as adjust mode Resize and comes back from a form page showing the keyboard, the view is shown as cut off with a white space where the keyboard used to be.

app.On<Xamarin.Forms.PlatformConfiguration.Android>().UseWindowSoftInputModeAdjust(WindowSoftInputModeAdjust.Resize);

Steps to reproduce in the attached project:

1. In the browse tab with beige background tap in Add Item option.
2. In the New Item view get focus over an entry where the keyboard is shown.
3. Don´t save, go back with the navigation bar back button. Don't use the "physical" android button.
4. Now the view seems cut off with a back space where the keyboard used to be.(See the adttached image)

Moreover, when the Android app is set as adjust mode Resize there is a white space on top where the status bar is, Moving all the screen down.

Please could I get a work around for the first problem while this is solve or check the sample project if there is something wrong with.
Comment 1 Diego 2017-04-25 13:31:38 UTC
Created attachment 21757 [details]
Error Image
Comment 2 Jimmy [MSFT] 2017-04-25 19:25:19 UTC
A fix for the status bar issue is under review: https://github.com/xamarin/Xamarin.Forms/pull/552

The main issue where the page content is cut off due to keyboard is being tracked as bug 45215

*** This bug has been marked as a duplicate of bug 45215 ***
Comment 3 Samantha Houts [MSFT] 2017-05-23 18:03:33 UTC
https://github.com/xamarin/Xamarin.Forms/pull/927