Bug 55542 - View in Master Content Page stops loading ListView in Detail
Summary: View in Master Content Page stops loading ListView in Detail
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-04-25 07:15 UTC by Gerco Brandwijk
Modified: 2017-07-12 06:27 UTC (History)
4 users (show)

Tags: android masterdetailpage view
Is this bug a regression?: Yes
Last known good build: 2.3.3.193


Attachments
Sample project (133.40 KB, application/x-zip-compressed)
2017-04-25 07:15 UTC, Gerco Brandwijk
Details
Attached are the logs generated during defect reproduction(Reopen) (2.74 KB, application/x-zip-compressed)
2017-06-29 10:29 UTC, Saurabh Paunikar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Gerco Brandwijk 2017-04-25 07:15:19 UTC
Created attachment 21742 [details]
Sample project

I am using the following configuration:

Default MasterDetailPage
- Master: MenuPage (some Label en some other views) based on ContentPage
- Detail: NavigationPage with BookingsPage (ListView) (based on ContentPage)

In the MenuPage I used a View to create a horizontal line, like this:
      <View HorizontalOptions="FillAndExpand"
            BackgroundColor="Black"
            HeightRequest="1" />

After upgrading to 2.3.4 suddenly my ListView in the BookingsPage was not loading. I did a lot of investigation, and I found out that that View in the MenuPage was the problem. When I replaced the <View> with a <BoxView> it worked again! So I replaced the <View> with this:

      <BoxView HorizontalOptions="FillAndExpand"
            BackgroundColor="Black"
            HeightRequest="1" />

I did not get any error, it was just not loading. When I displayed the BookingsPage as the Master, and the MenuPage inside the NavigationPage as the Detail, it was also working, so it looks like a combination of a <View> element that is used in the Master part of a MasterDetailPage.

You can reproduce this issue with the attached project. This project is the project that you get when you start a new Cross Platform project (PCL) with Visual Studio, so very basic stuff. In the AboutPage.xaml I added the <View> on line 47. When you leave this here, you will see that the ItemsPage will not load correctly, when you comment line 47, you will see that ItemsPage will load correctly.
Comment 1 Jimmy [MSFT] 2017-04-25 18:24:15 UTC
I am also seeing this issue when I run the attached project on Android. The issue does not occur on iOS. I am confirming this report so the team can investigate further.

### Workaround
As mentioned in the description, using a BoxView instead of a View will resolve the issue.

### Regression Test
2.3.5-pre1  BAD
2.3.4.231   BAD
2.3.3.193   GOOD
Comment 3 Rui Marinho 2017-05-04 14:29:14 UTC
Should be fixed on 2.3.5-pre3 and if we do a SR for 2.3.4
Comment 7 Saurabh Paunikar 2017-07-12 06:27:33 UTC
Verified on Xamarin.form version 2.3.5.256-pre6.

ScreenCast : https://www.screencast.com/t/avwCXLYPvAHA