Bug 55341 - Regression: Native crash while running tests with xunit with mono 2017-02 branch [needs test]
Summary: Regression: Native crash while running tests with xunit with mono 2017-02 bra...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Aleksey Kliger
URL:
Depends on: 53890
Blocks:
  Show dependency tree
 
Reported: 2017-04-18 18:08 UTC by Andi McClure
Modified: 2017-09-06 15:29 UTC (History)
7 users (show)

Tags: 2017-05, No_Shiproom
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andi McClure 2017-04-18 18:08:03 UTC
This issue has been fixed, this bugzilla is tracking the need for a regression test

+++ This bug was initially created as a clone of Bug #53890 +++

To reproduce:

$ git clone git@github.com:mono/msbuild.git
# xplat-master branch

$ ./cibuild.sh --scope Test --host Mono --target Mono

The above crashes while trying to run tests with xunit:

(partial trace here, full output log attached):
========

    at (wrapper managed-to-native) System.Runtime.Remoting.Proxies.RealProxy.InternalGetProxyType (object) <0x00012>
    at System.Runtime.Remoting.Proxies.RealProxy.GetProxiedType () [0x00027] in <6ee31efbdbd54ef9b1eb26def1af9a98>:0
    at System.Runtime.Remoting.Proxies.RemotingProxy.CanCastTo (System.Type,object) [0x00059] in <6ee31efbdbd54ef9b1eb26def1af9a98>:0
    at (wrapper runtime-invoke) <Module>.runtime_invoke_bool__this___object_object (object,intptr,intptr,intptr) [0x00059] in <6ee31efbdbd54ef9b1eb26def1af9a98>:0

...

      frame #3: 0x002226b9 mono`mono_arch_handle_altstack_exception(sigctx=<unavailable>, siginfo=<unavailable>, fault_addr=<unavailable>, stack_ovf=0) + 169 at exceptions-x86.c:1115 [opt]
      frame #4: 0x001058d2 mono`mono_sigsegv_signal_handler(_dummy=<unavailable>, _info=<unavailable>, context=<unavailable>) + 482 at mini-runtime.c:2857 [opt]
      frame #5: 0x9f98eebb libsystem_platform.dylib`_sigtramp + 43
      frame #6: 0x00248433 mono`mono_class_from_mono_type(type=0x0000006c) + 19 at class.c:6319 [opt]
      frame #7: 0x00345d93 mono`mono_type_get_object_checked(domain=0x78fb4090, type=0x0000006c, error=<unavailable>) + 51 at reflection.c:451 [opt]
      frame #8: 0x002786dc mono`ves_icall_Remoting_RealProxy_InternalGetProxyType(tp=0x00959580) + 44 at icall.c:6391 [opt]

==========

Also, complains:

EXEC : error : (i386) /Library/Frameworks/Mono.framework/Versions/4.9.3/lib/mono/4.5/mscorlib.dll.dylib empty dSYM file detected, dSYM was created with an executable with no debug info. [/Users/ankit/dev/msbuild/src/Framework.UnitTests/Microsoft.Build.Framework.UnitTests.csproj]

This is with mono 4.9.3.63 from the 2017-02 branch, built on wrench few hours back (06060e29).

Full output log is attached.

This works fine with mono 4.8.0.520 .

I was getting the same result with a recent 4.9.4.x, but I didn't try the latest from master.
Comment 1 Aleksey Kliger 2017-05-08 15:04:23 UTC
Changing importance since this is just about adding a regression test.
Comment 2 Marek Safar 2017-09-06 15:29:45 UTC
We run xunit as part of build now