Bug 55083 - coreclr test b353858.il fails after 6f33b62f39a273fccb78f71513cb5e0dfb987c70
Summary: coreclr test b353858.il fails after 6f33b62f39a273fccb78f71513cb5e0dfb987c70
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-04-12 12:50 UTC by Alexander Köplinger [MSFT]
Modified: 2017-04-13 21:03 UTC (History)
2 users (show)

Tags: 2017-04
Is this bug a regression?: ---
Last known good build:


Attachments
failing test (958 bytes, text/x-csrc)
2017-04-12 12:50 UTC, Alexander Köplinger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexander Köplinger [MSFT] 2017-04-12 12:50:10 UTC
It printed PASS before but now fails with:

>Unhandled Exception:
>System.TypeLoadException: Error getting the interfaces of System.Void[] due to Error Loading class >assembly:/Users/alexander/dev/mono/mcs/class/lib/net_4_x/mscorlib.dll type:IList`1 member:<none>
>  at <Module>.main () [0x00000] in <46786dc2546c451a8dd26471aa5312d4>:0
>[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Error getting the interfaces of System.Void[] due to Error Loading >class assembly:/Users/alexander/dev/mono/mcs/class/lib/net_4_x/mscorlib.dll type:IList`1 member:<none>
>  at <Module>.main () [0x00000] in <46786dc2546c451a8dd26471aa5312d4>:0

This was introduced in https://github.com/mono/mono/pull/4514
Comment 1 Alexander Köplinger [MSFT] 2017-04-12 12:50:31 UTC
Created attachment 21462 [details]
failing test
Comment 2 Zoltan Varga 2017-04-12 20:21:32 UTC
So calling typeof (void).MakeArrayType () is valid, but newarr void is not ?
Comment 3 Alexander Köplinger [MSFT] 2017-04-12 20:34:59 UTC
Looks like it, yes. Not sure if it's intentional ;)
Comment 4 Zoltan Varga 2017-04-13 20:41:28 UTC
Fixed in master e9f54cb051b9ba7ffbd41c5f9818978070e9a887.
Comment 5 Zoltan Varga 2017-04-13 21:00:48 UTC
-> FIXED.
Comment 6 Alexander Köplinger [MSFT] 2017-04-13 21:03:30 UTC
Thanks, I confirmed the fix works, reenabled the test and backported the fix to mono/2017-04!