Bug 5483 - Environment.Is64BitOperatingSystem returns a wrong value
Summary: Environment.Is64BitOperatingSystem returns a wrong value
Status: RESOLVED DUPLICATE of bug 37414
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: 2.10.x
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-03 01:37 UTC by Matthew
Modified: 2016-01-12 16:11 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 37414

Description Matthew 2012-06-03 01:37:47 UTC
Based on the mono mscorlib.dll source code, Environment.Is64BitOperatingSystem returns Environment.Is64BitProcess, which is wrong.
If you are running in WOW64 on windows, or the equivalent on linux/mac it should return true, not false.

What it should do, is if it is a x64 process then return true. If it is a x32 process, detect if it is a WOW64 process and return true if it is.
Comment 1 Alexander Köplinger [MSFT] 2016-01-12 16:11:13 UTC

*** This bug has been marked as a duplicate of bug 37414 ***