Bug 54659 - AXML autocompletion does not work
Summary: AXML autocompletion does not work
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer (show other bugs)
Version: 4.4.0 (15.1)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Stephen Shaw
URL:
Depends on:
Blocks:
 
Reported: 2017-04-06 18:36 UTC by Jeremy Kolb
Modified: 2017-10-03 16:47 UTC (History)
6 users (show)

Tags: vs ac
Is this bug a regression?: ---
Last known good build:


Attachments
logs (5.92 KB, application/x-zip-compressed)
2017-04-06 18:36 UTC, Jeremy Kolb
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Jeremy Kolb 2017-04-06 18:36:13 UTC
Created attachment 21277 [details]
logs

There is no intellisense or auto-completion for axml files in the source tab with either VS2015 or VS2017.
Comment 1 Pierce Boggan [MSFT] 2017-06-20 20:14:41 UTC
I can confirm that .axml IntelliSense is only partially working within the "Source" tab of the Android designer using the following environment information:
https://gist.github.com/pierceboggan/f1ffd9e92b04565eb494d4138e1a034a

IntelliSense works fine on the element attributes, but does not work on the elements themselves:
https://www.screencast.com/t/nO14p1iYy
Comment 2 Jérémie Laval 2017-08-25 19:41:09 UTC
In your screencast you are trying to complete an element inside an element (you have a closing tag '/>') so the VS parser simply doesn't recognize this as a case where you would have an element completion.

The attribute name completion seems strange for its namespace so we will check that.
Comment 3 Stephen Shaw 2017-08-28 21:28:55 UTC
From what I can see so far if you are seeing "a:" instead of "android:" then something is incorrect and VS xsd validation is defaulting to some state.

@jeremy If you can easily reproduce this can you provide some steps. Also, if you can attach the folder with the XSD files in it to the bug that'd be very helpful. It is located in the project's "obj\Debug\Schemas\{api_level}" folder. The "{api_level}" will vary, but is likely "25". There should be about 4 files.
Comment 4 Pierce Boggan [MSFT] 2017-10-03 16:47:17 UTC
Because we have not received a reply to our request for more information in over 14 days, we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information so we can continue looking into this. Thanks!