Bug 5448 - Razor compilation errors not reported correctly.
Summary: Razor compilation errors not reported correctly.
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: 2.10.x
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-06-01 01:39 UTC by gcaseres
Modified: 2012-06-01 01:39 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 5448 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description gcaseres 2012-06-01 01:39:14 UTC
When I have a syntax error in my razor views, I receive a "View not found" exception:

"The view '[ViewName]' or its master was not found or no view engine supports the searched locations. The following locations were searched:...."

I tried to find the problem and I detected that the real compilation error (with real feedback about the line where the error has occured) is shown in Console.Error.

The exception should be thrown by the BuildManager (System.Web.Compilation) instead of being reported in Console.Error.

I'm using Microsoft MVC 3 (System.Web.Mvc) and Mono 2.10.8.

Sorry for my bad English.

Any suggestion or workaround will be appreciated.