Bug 54298 - Unhandled Exception: "Constructing instances of generic types from Java is not supported" running RuntimeTests suite
Summary: Unhandled Exception: "Constructing instances of generic types from Java is no...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.2 (15.1)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2017-03-30 14:27 UTC by Gonzalo Martin
Modified: 2017-10-13 17:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Gonzalo Martin 2017-03-30 14:27:31 UTC
Category: "EnableSGenConcurrentTests"
Location: XQA.Android/XA7

Step:
- Download and run (device/emulator) the Runtime test suite for monodroid/d15.1

Expected Result: 
- tests passed

Actual Result: 
- tests failed with exception

UNHANDLED EXCEPTION:
03-30 10:55:04.123 I/MonoDroid( 5262): System.NotSupportedException: Constructing instances of generic types from Java is not supported, as the type parameters cannot be determined. ---> Java.Interop.JavaLocationException: Exception of type 'Java.Interop.JavaLocationException' was thrown.
03-30 10:55:04.123 I/MonoDroid( 5262):    --- End of inner exception stack trace ---
03-30 10:55:04.123 I/MonoDroid( 5262):   at Java.Interop.TypeManager.n_Activate (System.IntPtr jnienv, System.IntPtr jclass, System.IntPtr typename_ptr, System.IntPtr signature_ptr, System.IntPtr jobject, System.IntPtr parameters_ptr) [0x00180] in /Users/builder/data/lanes/4468/3cb10f5e/source/xamarin-android/src/Mono.Android/Java.Interop/TypeManager.cs:176 
03-30 10:55:04.123 I/MonoDroid( 5262):   at (wrapper dynamic-method) System.Object:bf8550f3-537f-4405-bce9-ceb395e3074f (intptr,intptr,intptr,intptr,intptr,intptr)
03-30 10:55:04.130 W/art     ( 5262): JNI RegisterNativeMethods: attempt to register 0 native methods for android.runtime.JavaProxyThrowable
03-30 10:55:04.133 D/Mono    ( 5262): DllImport searching in: '__Internal' ('(null)').
03-30 10:55:04.133 D/Mono    ( 5262): Searching for 'java_interop_jnienv_throw'.
03-30 10:55:04.133 D/Mono    ( 5262): Probing 'java_interop_jnienv_throw'.
03-30 10:55:04.133 D/Mono    ( 5262): Found as 'java_interop_jnienv_throw'.


Environment Info: https://gist.github.com/gonzalonm/509ac3cb52e4d86af55a6b2bf2c5ea5f
Comment 2 Cody Beyer (MSFT) 2017-07-13 21:08:57 UTC
Unfortunately, we’re unable to reproduce this report. If this issue is still occurring for you, please reopen this issue and attach a reproduction to the bug by starting with a clean Xamarin.Android project adding just the code necessary to demonstrate the issue.
Comment 3 Jon Douglas [MSFT] 2017-10-13 17:53:33 UTC
RESOLVING this bug as per https://bugzilla.xamarin.com/show_bug.cgi?id=54298#c2