This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 5423 - Hanging in MonoTouch exception handling code on device
: Hanging in MonoTouch exception handling code on device
Status: RESOLVED NORESPONSE
Product: iOS
Classification: Xamarin
Component: Runtime
: 5.2
: PC Mac OS
: --- normal
: Untriaged
Assigned To: Bugzilla
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-05-30 18:11 EDT by jesse.attas
Modified: 2013-12-05 18:36 EST (History)
2 users (show)

See Also:
Tags:
Test Case URL:
External Submit: ---


Attachments

Description jesse.attas 2012-05-30 18:11:27 EDT
Since the 3.0 update, unhanded C# exceptions are no longer generating useful
call stacks and crash reports on the iPad (it works fine in the simulator). It
appears that the MonoTouch exception handler is hanging while trying to handle
the exception thrown from our code. This makes it difficult to debug our
exceptions as we can't see the type or message of the exception.

If you kill the app after it gets into this state, often you will not be able
to relaunch it until you reboot the device. It just gives you a black screen
that stays up until the OS kills the app for taking too long to launch.

Here's part of an example call stack:
0x01eeb786 mono_aot_find_jit_info (aot-runtime.c:1661)
0x01f260de mono_jit_info_table_find (domain.c:445)
0x01eef812 mini_jit_info_table_find (mini-exceptions.c:1035)
0x01eefcda mono_find_jit_info_ext (mini-exceptions.c:356)
0x01ef014c 0x1000 + 32436556
0x01ef0cbe 0x1000 + 32439486
0x01ef12a2 mono_handle_exception (mini-exceptions.c:1828)
0x01f08e46 handle_signal_exception (exceptions-arm.c:532)
0x00b4f4a8
mscorlib_System_Collections_Generic_List_1_AddEnumerable_System_Collections_Generic_IEnumerable_1_T
(mscorlib.dll.7.s:75812)
0x00b4f4a8
mscorlib_System_Collections_Generic_List_1_AddEnumerable_System_Collections_Generic_IEnumerable_1_T
(mscorlib.dll.7.s:75812)
0x00b4ef68
mscorlib_System_Collections_Generic_List_1__ctor_System_Collections_Generic_IEnumerable_1_T
(mscorlib.dll.7.s:75325)
0x00a8dbe4
System_Core_System_Linq_Enumerable_ToList_TSource_System_Collections_Generic_IEnumerable_1_TSource
(System.Core.dll.7.s:9729)
0x00dc6e60 

And here's my version info:

MonoDevelop 3.0 (3.0.1)
Installation UUID: 1480f558-ce01-4cc9-8f58-058dda76f061
Runtime:
    Mono 2.10.9 (tarball Mon May  7 20:25:51 EDT 2012)
    GTK 2.24.10
    GTK# (2.12.0.0)
    Package version: 210090011
Apple Developer Tools:
     Xcode 4.3.2 (1177)
     Build 4E2002
Monotouch: 5.2.12
Mono for Android not installed
Build information:
    Release ID: 30001000
    Git revision: 6642975fcf75fabbaf71a2ce79cdd65cd7db812a-dirty
    Build date: 2012-05-14 11:09:56+0000
    Xamarin addins: a1563f182f5d7a68e0ba06beda0a39f9fe073016
Operating System:
    Mac OS X 10.7.4
Comment 1 Rolf Bjarne Kvinge 2012-05-31 08:41:44 EDT
I believe this has been fixed in the upcoming 5.3.4 release, which should be
released today or tomorrow. Can you try that release to see if the same thing
happens? Or maybe you can create a complete test case we can try out ourselves?
Comment 2 jesse.attas 2012-05-31 10:45:52 EDT
I'll update when it's released and let you know if we still see this. Thanks!
Comment 3 PJ 2013-11-19 17:05:54 EST
This bug has been in the NEEDINFO state with no changes for the last 90 days.
Can we put this back into the NEW or CONFIRMED state, or are we still awaiting
response?

If there is no change in the status of this bug over the next two weeks, this
bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:36:21 EST
This bug has not been changed from the NEEDINFO state since my previous
comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing
the issue. Please add the requested information and set the bug back to the NEW
(or CONFIRMED) state.

Note You need to log in before you can comment on or make changes to this bug.