Bug 53848 - [UWP] Sotware Navigation Bar not taken into consideration when rendering pages in certain cases.
Summary: [UWP] Sotware Navigation Bar not taken into consideration when rendering page...
Status: RESOLVED DUPLICATE of bug 42055
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-23 11:56 UTC by Novak Savic
Modified: 2017-03-23 13:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction Example 1 (319.55 KB, application/x-zip-compressed)
2017-03-23 11:56 UTC, Novak Savic
Details
Reproduction Example 2 (234.50 KB, application/x-zip-compressed)
2017-03-23 11:56 UTC, Novak Savic
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42055

Description Novak Savic 2017-03-23 11:56:04 UTC
I notice the problem that can be reproduced in UWP.

I'm using the following for testing:
Device: Microsoft RM-1104 
OS: Win Phone 10.0.14393.693.

This device does not have hardware navigation button bar, so it uses software navigation bar.
It seems that for certain cases software navigation bar is not taken into account when calculating height for view available to render page, which has effect that page is snow from the bottom of the screen up to status bar, but it should be from software navigation bar up to status bar.

So part of page is hidden by software navigation bar.

This can be reproduced in the following cases:
1. The simplest project (not masterdetail) with one page. There is an example solution attached. 
Main page contains grid with 4 rows:
- Row 1: label at top
- Row 2: label at center
- Row 3: Button (when clicked enter/leave full screen)
- Row 4: label at bottom. When not in full screen mode this , this 

2. For master detail:
- When page is pushed from detail page, all good
- When modal page is pushed from details page, not good.

See examples provided.
Comment 1 Novak Savic 2017-03-23 11:56:32 UTC
Created attachment 20740 [details]
Reproduction Example 1
Comment 2 Novak Savic 2017-03-23 11:56:48 UTC
Created attachment 20741 [details]
Reproduction Example 2
Comment 3 Novak Savic 2017-03-23 13:32:01 UTC

*** This bug has been marked as a duplicate of bug 42055 ***