Bug 53845 - Build error: The file 'LaunchScreen.storyboard' conflicts with 'Resources/LaunchScreen.storyboard'
Summary: Build error: The file 'LaunchScreen.storyboard' conflicts with 'Resources/Lau...
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: XI 10.8 (d15-1)
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.1
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-23 11:07 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2017-03-23 11:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Rolf Bjarne Kvinge [MSFT] 2017-03-23 11:07:49 UTC
Repro:

* Clone/checkout https://github.com/xamarin/ios-samples
* Build CustomTransitions/CustomTransitions.sln

Result:

> LaunchScreen.storyboard: error : The file 'LaunchScreen.storyboard' conflicts with 'Resources/LaunchScreen.storyboard'.

This happens with the dev15.1 version of Xamarin.iOS.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-03-23 11:09:41 UTC
The problem is that the project is invalid; LaunchScreen.storyboard is duplicated in the project:

> LaunchScreen.storyboard
> Resources/LaunchScreen.storyboard

The fix is to remove one of the storyboards.