Bug 53832 - Getting The file 'Resources/LaunchScreen.storyboard' conflicts with 'LaunchScreen.storyboard' error while deploying FilterDemoApp sample
Summary: Getting The file 'Resources/LaunchScreen.storyboard' conflicts with 'LaunchSc...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples (show other bugs)
Version: XI 10.8 (d15-1)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Ivan Herrera
URL:
Depends on:
Blocks:
 
Reported: 2017-03-23 06:35 UTC by Saurabh Paunikar
Modified: 2017-08-04 13:09 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attaching detail output,screenshot and IDE logs (73.51 KB, application/zip)
2017-03-23 06:35 UTC, Saurabh Paunikar
Details
Logs (37.83 KB, application/zip)
2017-04-14 07:26 UTC, Roshan Mankani
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Saurabh Paunikar 2017-03-23 06:35:12 UTC
Created attachment 20713 [details]
Attaching detail output,screenshot and IDE logs

Steps:

1.Clone FilterDemoApp sample from https://github.com/xamarin/ios-samples
2.Run the project

Expected result: Build should get deployed successfully.
Actual result: Getting The file 'Resources/LaunchScreen.storyboard' conflicts with 'LaunchScreen.storyboard' error.


Screencast: https://www.screencast.com/t/KVhsgkfF4ghy

Also attaching detail output,screenshot and IDE logs


Environment I used is as follow

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Enterprise

Architecture and Modeling Tools   00322-80000-00000-AA364
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

LightSwitch for Visual Studio 2015   00322-80000-00000-AA364
Microsoft LightSwitch for Visual Studio 2015

Visual Basic 2015   00322-80000-00000-AA364
Microsoft Visual Basic 2015

Visual C# 2015   00322-80000-00000-AA364
Microsoft Visual C# 2015

Visual C++ 2015   00322-80000-00000-AA364
Microsoft Visual C++ 2015

Visual F# 2015   00322-80000-00000-AA364
Microsoft Visual F# 2015

Windows Phone SDK 8.0 - ENU   00322-80000-00000-AA364
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   7.18.00214.2
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11107.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Clang with Microsoft CodeGen   14.0.25516
Clang with Microsoft CodeGen

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   2.2.0.8
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

KofePackagePackage Extension   1.0
KofePackagePackage Visual Studio Extension Detailed Info

Merq   1.1.14-alpha (21c13c9)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2015 ENU   14.0.23025
Microsoft Office Developer Tools for Visual Studio 2015 ENU

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

Python Tools for Visual Studio   2.2.50113.00
Python Tools for Visual Studio provides IntelliSense, projects, templates, Interactive windows, and other support for Python developers.

Python Tools for Visual Studio - Django Integration   2.2.50113.00
Provides templates and integration for the Django web framework.

Python Tools for Visual Studio - Profiling Support   2.2.50113.00
Profiling support for Python projects.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Visual C++ for Cross Platform Mobile Development (Android)   14.0.25401.00
Visual C++ for Cross Platform Mobile Development (Android)

Visual C++ for Cross Platform Mobile Development (iOS)   14.0.25401.00
Visual C++ for Cross Platform Mobile Development (iOS)

Visual Studio Tools for Apache Cordova   Update 10
Visual Studio Tools for Apache Cordova

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   4.4.0.7 (0b7edd0)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.2.0.6 (b8e3884)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.8.0.26 (0e9e791)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-03-23 11:17:17 UTC
Same issue with a different sample: bug #52848.

There's a public-facing bug here: bug #53845.
Comment 2 GouriKumari 2017-03-23 13:01:18 UTC
@ivan: Could you fix these samples: Custom Transitions, FilterDemo?
Comment 3 Ivan Herrera 2017-03-23 14:16:45 UTC
(In reply to GouriKumari from comment #2)
> @ivan: Could you fix these samples: Custom Transitions, FilterDemo?

Sure
Comment 4 Ivan Herrera 2017-04-05 14:00:07 UTC
Fixed in:

https://github.com/xamarin/ios-samples/pull/158
Comment 5 Roshan Mankani 2017-04-14 07:26:19 UTC
Created attachment 21531 [details]
Logs

The Issue is still coming,

Steps:

1.Clone FilterDemoApp sample from https://github.com/xamarin/ios-samples
2.Run the project

Expected result: Build should get deployed successfully.
Actual result: Getting The file 'Resources/LaunchScreen.storyboard' conflicts with 'LaunchScreen.storyboard' error.

Screencast:https://www.screencast.com/t/3FS9M7mowb

Logs: logs are attached 53832_Logs.zip.

Environment I used is as follow

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Architecture and Modeling Tools   00322-80000-00000-AA388
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Visual Basic 2015   00322-80000-00000-AA388
Microsoft Visual Basic 2015

Visual C# 2015   00322-80000-00000-AA388
Microsoft Visual C# 2015

Visual C++ 2015   00322-80000-00000-AA388
Microsoft Visual C++ 2015

Visual F# 2015   00322-80000-00000-AA388
Microsoft Visual F# 2015

Application Insights Tools for Visual Studio Package   7.18.00214.2
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11107.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Xamarin   4.5.0.346 (df610b7)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.3.0.5 (40f69c3)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.10.0.4 (9245c1c)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 6 Ivan Herrera 2017-04-21 12:52:45 UTC
Need to update my Visual Studio for Windows setup and try there.

Against the Mac env runs flawless.
Comment 7 GouriKumari 2017-04-24 16:42:01 UTC
I can still reproduce this issue with VSfMac with alpha builds and XS with stable builds.

## Build Log:

VSfMac: https://gist.github.com/GouriKumari/925e19c3fa8cfb951dc8b7fe51649ea6
XS: https://gist.github.com/GouriKumari/0d7566396d2bd110ce8976cfee1009f2

@ivan: You updated the sample AuV3Host, But FilterDemo.csproj also needs to be updated. 

##Test Env:
https://gist.github.com/GouriKumari/cd026cc0765ee7b1de6c4c58a8a098a8
Comment 8 Sebastien Pouliot 2017-04-26 12:31:56 UTC
@Ivan can you double check this based on Gouri comments ? thanks!
Comment 9 Sebastien Pouliot 2017-05-04 12:47:29 UTC
ping ?
Comment 10 Ivan Herrera 2017-05-08 15:25:46 UTC
Fixed in https://github.com/xamarin/ios-samples/pull/163
Comment 11 Sebastien Pouliot 2017-05-08 15:35:36 UTC
Thanks, let's merge the PR and close this bug
Comment 12 Sebastien Pouliot 2017-05-15 19:20:20 UTC
PR (on sample) merged
Comment 13 Saurabh Paunikar 2017-08-04 13:09:35 UTC
Downloaded FilterDemoApp  sample from on 04-aug-2017 from https://github.com/xamarin/ios-samples

Verified on Xamarin 4.7.0.868. Verified on D-15.4 as this was sample issue 

Detailed build info
https://gist.github.com/aman-daharwal/429cb123a23c6b12ce800d4a96ee1fad

ScreenCast link: https://www.screencast.com/t/ciYg0ZGdog7