Bug 53792 - CFNetworkHandler reports correct download when internet connection is lost during request
Summary: CFNetworkHandler reports correct download when internet connection is lost du...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 10.3 (iOS 10.2)
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.3
Assignee: Manuel de la Peña [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-22 17:31 UTC by Manuel de la Peña [MSFT]
Modified: 2017-07-14 07:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test application (11.67 KB, application/zip)
2017-04-26 08:50 UTC, Manuel de la Peña [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Manuel de la Peña [MSFT] 2017-03-22 17:31:20 UTC
The iOS implementation does not work as expected when the phone is disconnected. The issue is that the stream reports and error after the response has been set to be completed which means that the stream gets closed and the request is concluded as everything was correct.
Comment 3 Manuel de la Peña [MSFT] 2017-04-26 08:50:41 UTC
Created attachment 21790 [details]
Test application

Application that can be used to test the fix. Start the application, a download will start and remove the device connection during the download (airplane mode) and an exception should be raised instead of the download being completed.
Comment 4 Manuel de la Peña [MSFT] 2017-05-10 17:10:49 UTC
Please QA can you take this for a spin.