Bug 53787 - Application crashes onto the Simulator and Physical device when running on Debug mode
Summary: Application crashes onto the Simulator and Physical device when running on De...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 7.0 (VSforMac)
Hardware: PC Mac OS
: High blocker
Target Milestone: 15.2
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2017-03-22 13:23 UTC by Chiranjib Mukherjee
Modified: 2017-03-31 10:46 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: 7.0.0.1796 (master)


Attachments
Console Logs (104.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-22 13:23 UTC, Chiranjib Mukherjee
Details
Attaching Logs (8.91 KB, text/plain)
2017-03-22 13:33 UTC, Chiranjib Mukherjee
Details
Attaching Logs_1 (10.51 KB, text/plain)
2017-03-22 13:33 UTC, Chiranjib Mukherjee
Details
Screencast Link - https://www.screencast.com/t/lFDTF0B8sjQ (104.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-22 13:41 UTC, Chiranjib Mukherjee
Details
Android device logs (119.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-23 07:50 UTC, Chiranjib Mukherjee
Details
Logs_1 (10.85 KB, text/plain)
2017-03-24 10:58 UTC, Chiranjib Mukherjee
Details
Logs_2 (9.41 KB, text/plain)
2017-03-24 10:58 UTC, Chiranjib Mukherjee
Details
Attached packaging and package console logs (71.12 KB, application/zip)
2017-03-24 11:35 UTC, Neeraj Deshmukh
Details
Logs_1 (25.71 KB, text/plain)
2017-03-28 09:22 UTC, Chiranjib Mukherjee
Details
Logs_2 (25.71 KB, text/plain)
2017-03-28 09:23 UTC, Chiranjib Mukherjee
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Chiranjib Mukherjee 2017-03-22 13:23:11 UTC
Created attachment 20672 [details]
Console Logs

Description: Application crashes onto the Simulator and Physical device when running on Debug mode

Steps to reproduce:
- Create an Android Application
- Build the created application
- Run the created application onto an Android physical device or Simulator

Expected Result - Application should be created and run successfully

Actual Result - Application crashes on the Simulator and Physical device 

Environment Details:
Visual Studio for Mac Preview
Version Preview 5 (7.0 build 1770)
Installation UUID: 0dddd93d-6d83-4539-a8cd-2edf7e9e8564
Runtime:
	Mono 4.9.3.43 (2017-02/9ecfd9f) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 409030043

NuGet
Version: 4.0.0.2323

Xamarin.Profiler
Version: 1.4.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 8.2.1 (11766.1)
Build 8C1002

Xamarin.iOS
Version: 10.9.0.73 (Visual Studio Enterprise)
Hash: 818c20b
Branch: master
Build date: 2017-03-21 12:28:31-0400

Xamarin.Android
Version: 7.2.99.67 (Visual Studio Enterprise)
Android SDK: /Users/globallogic/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.4 (API level 19)
		6.0 (API level 23)
		7.0 (API level 24)
		7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.3
SDK Build Tools Version: 25.0.1

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin.Mac
Version: 3.3.0.73 (Visual Studio Enterprise)

Xamarin Inspector
Version: 1.2.0-rc.3
Hash: 5e5e341
Branch: d15-1
Build date: Fri, 10 Mar 2017 22:41:39 GMT

Build Information
Release ID: 700001770
Git revision: 50bb644bd06636db7479fd53343d4afc6a8c619e
Build date: 2017-03-17 13:07:11-04
Xamarin addins: 01c055caee599112329c7803dd881d041f33d43a
Build lane: monodevelop-lion-android-deploy

Operating System
Mac OS X 10.12.0
Darwin NAG1-LMAC-N07154 16.0.0 Darwin Kernel Version 16.0.0
    Mon Aug 29 17:56:20 PDT 2016
    root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64
Comment 1 Chiranjib Mukherjee 2017-03-22 13:33:07 UTC
Reproducibility Ratio : 8/10
Comment 2 Chiranjib Mukherjee 2017-03-22 13:33:25 UTC
Created attachment 20675 [details]
Attaching Logs
Comment 3 Chiranjib Mukherjee 2017-03-22 13:33:42 UTC
Created attachment 20676 [details]
Attaching Logs_1
Comment 4 Chiranjib Mukherjee 2017-03-22 13:41:02 UTC
Created attachment 20681 [details]
Screencast Link - https://www.screencast.com/t/lFDTF0B8sjQ
Comment 5 Greg Munn 2017-03-22 15:02:29 UTC
Can you add the logs from the Device Log too (in XS you can select View | Pads | Device Log) and then select the device. Wait until the log loads fully (on a real device you will continue to get a lot of events, so maybe do this with an emulator). Then, add a "marker" to the log, deploy, add another marker, then interact with the app to make it crash. Then select all the events and paste into a file and attach.

You can also do something similar with `adb logcat` and redirect the output from that to a file.

Given that the application was deployed, it's likely that this isn't related to XS - also, since all the deployment is done by Xamarin Android now XS has no control of what is or isn't deployed to the device.
Comment 6 Jacky Waswani 2017-03-23 07:46:15 UTC
Hello @Greg,

As suggested, I have attached the device logs. I have applied marker before deployment(marker 1) & after deployment(marker 2).

Device details: Nexus 6P OS 6.0.
Comment 7 Chiranjib Mukherjee 2017-03-23 07:50:25 UTC
Created attachment 20718 [details]
Android device logs

Attaching the device logs.
Comment 8 Greg Munn 2017-03-23 14:38:25 UTC
can we just use a plain text file instead of a .docx file?
Comment 9 Greg Munn 2017-03-23 14:38:55 UTC
or gist.github.com
Comment 11 Greg Munn 2017-03-23 14:43:53 UTC
@dean, can you take a look please.
Comment 12 Kyle White 2017-03-23 14:59:55 UTC
I am able to repro and @dean asked for the diagnostic output od `msbuild /t:Install` which is here:
https://gist.github.com/kdubau/3f0e64d8b321cab379277a879a6d7ee1
Comment 13 dean.ellis 2017-03-23 15:08:12 UTC
adb log output 

https://gist.github.com/dellis1972/62bf746a794ccf4865dea6779aa73c0e
Comment 14 Cody Russell 2017-03-23 16:36:30 UTC
I've tried reproducing this morning and I'm unable to. Everything seems to be working here. :/
Comment 15 Cody Russell 2017-03-23 17:03:51 UTC
I think the difference was my Mono. When I was using the same versions of VSMac and Monodroid everything was fine, but I was still using Mono 4.8.0. When I switched to Mono 4.9.3.43 then the app crashed.
Comment 16 Andi McClure 2017-03-23 21:19:58 UTC
I am seeing this 100% currently.
Comment 17 dean.ellis 2017-03-24 09:48:13 UTC
Should be fixed in monodroid/master/310823bc
Comment 18 Chiranjib Mukherjee 2017-03-24 10:57:56 UTC
Now i can see a different pop up coming up and it stops the application to be deployed over the Physical device and Emulator

PFA - Attached Screencast Link - https://www.screencast.com/t/8KEVl526lt5
Comment 19 Chiranjib Mukherjee 2017-03-24 10:58:14 UTC
Created attachment 20787 [details]
Logs_1
Comment 20 Chiranjib Mukherjee 2017-03-24 10:58:34 UTC
Created attachment 20788 [details]
Logs_2
Comment 21 dean.ellis 2017-03-24 11:00:39 UTC
a bit more investigation and it looks like msbuild is ignoring the DebugType property in projects. It always defaults to "portable" which breaks x-a because we only use the debug runtime when DebugType is "Full".
Comment 22 Neeraj Deshmukh 2017-03-24 11:35:34 UTC
Created attachment 20793 [details]
Attached packaging and package console logs
Comment 23 dean.ellis 2017-03-24 11:55:20 UTC
I think this is related to Bug 53900
Comment 24 dean.ellis 2017-03-27 14:34:49 UTC
Fixed on monodroid/master/c53f856c
Comment 25 Chiranjib Mukherjee 2017-03-28 09:22:29 UTC
Checked with the latest XA and Mono version.

Working Fine, hence closing the Bug.

PFA - Attached Logs

Thanks.
Comment 26 Chiranjib Mukherjee 2017-03-28 09:22:48 UTC
Created attachment 20937 [details]
Logs_1
Comment 27 Chiranjib Mukherjee 2017-03-28 09:23:05 UTC
Created attachment 20938 [details]
Logs_2