Bug 53622 (vs-561850) - [Xamarin-Studio] Usability: Voiceover: Voiceover reads invisible elements in the 'Project Options' Window.
Summary: [Xamarin-Studio] Usability: Voiceover: Voiceover reads invisible elements in ...
Status: CLOSED FIXED
Alias: vs-561850
Product: Xamarin Studio
Classification: Desktop
Component: Accessibility (show other bugs)
Version: 7.2 (d15-4)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: iain
URL:
: 53595 53604 53609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-21 10:16 UTC by Naveen Katakam
Modified: 2018-06-22 20:30 UTC (History)
4 users (show)

Tags: Accessibility,Wipro,A11yUsable,Xamarin-Studio,vs-sync
Is this bug a regression?: ---
Last known good build:


Attachments
Invisible rect in VoiceOver Project Options dialog (134.68 KB, image/png)
2017-08-25 18:50 UTC, Kirill Osenkov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Naveen Katakam 2017-03-21 10:16:25 UTC
Testing Environment: 
macOS Sierra v 10.12.3
Xamarin v6.3 (Build 731)

Repro Steps:
1. Launch Xamarin Studio.
2. Turn ON Voiceover.
3. Open an existing file or create a new project.
4. Goto project.droid (or any available project) --> Project options window.
5. Goto 'General --> Main Settings' menu pane.
6. Navigate using VO+Arrow keys in the pane.

Note:
Issue also exists in following panes;
1. Build --> General.
2. Build --> Compiler
3. Build --> Output
4. NuGet Package --> Metadata --> General&Details tab.

Expected Behavior:
Voicover should announce all the visible items present in the Startup window.

Actual Behavior:
Voiceover announces extra elements in the window that are invisible to user.

User Impact:
Visually impaired users relying on screen readers will be affected. Voiceover conveys information that is not present.

Repro Video:

Please find the attachments in below link;

https://microsoft-my.sharepoint.com/personal/v-glvela_microsoft_com/_layouts/15/guestaccess.aspx?guestaccesstoken=rFOFnkGFch7cDYwxZnZo%2b1c0B5PXgKgHxGPrxO%2bm9R8%3d&folderid=2_14e201b111b4c44e6806b892a0431098e&rev=1
Comment 1 iain 2017-05-26 11:07:41 UTC
*** Bug 53595 has been marked as a duplicate of this bug. ***
Comment 2 iain 2017-05-26 11:17:34 UTC
*** Bug 53604 has been marked as a duplicate of this bug. ***
Comment 3 iain 2017-05-26 11:23:16 UTC
*** Bug 53609 has been marked as a duplicate of this bug. ***
Comment 4 iain 2017-07-21 09:36:40 UTC
Should be fixed in master
Comment 5 Ramya Sri Narasinga 2017-07-24 06:43:43 UTC
Bug is checked in

macOS Sierra v10.12.5
Visual Studio for Mac enterprise v7.2 Preview (7.2 build 352).

Issue still exists. Could you please provide the latest build to verify this bug ??
Comment 6 Naveen Katakam 2017-08-02 10:25:55 UTC
Bug is checked in

macOS Sierra v10.12.5
Visual Studio for Mac enterprise v7.2 Preview (7.2 build 352).

Issue still exists.Hence reactivating the bug.

Could you please provide the latest build to verify this bug ??

Thank you.
Comment 7 Kirill Osenkov 2017-08-25 18:50:15 UTC
Created attachment 24425 [details]
Invisible rect in VoiceOver Project Options dialog
Comment 8 Kirill Osenkov 2017-08-25 18:51:16 UTC
Indeed I can still repro on 7.2.487.