Bug 53611 - Usability: Voiceover: Voiceover doesnt announce the position of the list items.
Summary: Usability: Voiceover: Voiceover doesnt announce the position of the list items.
Status: CLOSED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Accessibility (show other bugs)
Version: 6.3 (15.1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: iain
URL:
Depends on:
Blocks:
 
Reported: 2017-03-21 07:23 UTC by Ramya Sri Narasinga
Modified: 2017-10-07 11:11 UTC (History)
1 user (show)

Tags: Accessibility,Wipro,A11yUsable,Xamarin-Studio,TrueInvalid
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED INVALID

Description Ramya Sri Narasinga 2017-03-21 07:23:37 UTC
Testing Environment: 
macOS Sierra v 10.12.3
Xamarin v6.3 (Build 731)

Repro Steps:
1. Launch Xamarin Studio.
2. Turn ON Voiceover.
3. Hit VO+M to goto menu item.
4. Goto any menu item (Eg: File) and hit VO+Space.
5. Observe VO Behavior.

Note:
Issue also exists for all menu items and also its sub-menu items.

Expected Behavior:
Voiceover should announce the total list item present and the position of individual list item when navigated.

Actual Behavior:
Voiceover announces the total list item but doesn't announce the position of individual list item.

User Impact:
Users relying on Voiceover will not know the position of the list item and the remaining list items to navigate till the end.

Repro Video:

Please find the attachments in below link;

https://microsoft-my.sharepoint.com/personal/v-glvela_microsoft_com/_layouts/15/guestaccess.aspx?guestaccesstoken=gA3eFY6P9Jfb3T5%2f22JhfgkhM4ZyuwJdPepikx%2feVyA%3d&folderid=2_1eed10f6f466444d6b58cc4d9b700a45b&rev=1
Comment 1 iain 2017-09-08 17:25:58 UTC
This is VoiceOver's behaviour and not something we can do anything about.
Comment 2 Ramya Sri Narasinga 2017-10-07 05:56:17 UTC
Since this is VO behaviour closing this bug.