Bug 53589 - MethodAccessException on initializing AzureClient after arrival of push notification on Nougat, Nexus 5X
Summary: MethodAccessException on initializing AzureClient after arrival of push notif...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: unspecified
Hardware: Other Other
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2017-03-20 21:38 UTC by Dennis
Modified: 2017-10-13 18:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Dennis 2017-03-20 21:38:04 UTC
android.runtime.JavaProxyThrowable: System.MethodAccessException: Method `Microsoft.WindowsAzure.MobileServices.PlatformInformation:get_Version ()' is inaccessible from method `Microsoft.WindowsAzure.MobileServices.PlatformInformationExtensions:GetVersionFromAssemblyFileVersion (Microsoft.WindowsAzure.MobileServices.IPlatformInformation)'

caused.PlatformInformation()
System.Object.__icall_wrapper_mono_throw_method_access(intptr, intptr)(wrapper managed-to-native)
Microsoft.WindowsAzure.MobileServices.PlatformInformation.get_Version()<c9431a6fad8f43d390390fe548a9b1bf>:0
Microsoft.WindowsAzure.MobileServices.MobileServiceHttpClient.GetUserAgentHeader()<ab12dd35a79843cbbb4e1cdb3ddf7427>:0
Microsoft.WindowsAzure.MobileServices.MobileServiceHttpClient.MobileServiceHttpClient(IEnumerable<T> handlers, Uri applicationUri, string installationId)<ab12dd35a79843cbbb4e1cdb3ddf7427>:0
Microsoft.WindowsAzure.MobileServices.MobileServiceClient.MobileServiceClient(Uri mobileAppUri, HttpMessageHandler[] handlers)<ab12dd35a79843cbbb4e1cdb3ddf7427>:0
Microsoft.WindowsAzure.MobileServices.MobileServiceClient.MobileServiceClient(string mobileAppUri, HttpMessageHandler[] handlers)<ab12dd35a79843cbbb4e1cdb3ddf7427>:0
Kudizmo.AzureClient.AzureClient.CreateClient()<560e234b5b734c69b5334a0d1ca1a685>:0
Kudizmo.AzureClient.AzureClient.get_Client()<560e234b5b734c69b5334a0d1ca1a685>:0
Kudizmo.Droid.Helpers.PushHandlerService.<OnRegistered>d__8.MoveNext()<08cf2cefecb84c4eb3e93013d29dca3a>:0
System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(object state)<4b972182e4df431898b1377813260900>:0
System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, object state, bool preserveSyncCtx)<4b972182e4df431898b1377813260900>:0
System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, object state, bool preserveSyncCtx)<4b972182e4df431898b1377813260900>:0
System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()<4b972182e4df431898b1377813260900>:0
System.Threading.ThreadPoolWorkQueue.Dispatch()<4b972182e4df431898b1377813260900>:0
System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()<4b972182e4df431898b1377813260900>:0

https://github.com/Azure/azure-mobile-services/blob/master/sdk/Managed/src/Microsoft.WindowsAzure.MobileServices/Http/MobileServiceHttpClient.cs
Comment 1 Cody Beyer (MSFT) 2017-07-07 20:49:06 UTC
Unfortunately, we’re unable to reproduce this report. If this issue is still occurring for you, please reopen this issue and attach a reproduction to the bug by starting with a clean Xamarin.Android project adding just the code necessary to demonstrate the issue.
Comment 2 Jon Douglas [MSFT] 2017-10-13 18:20:32 UTC
RESOLVING based on https://bugzilla.xamarin.com/show_bug.cgi?id=53589#c1