Bug 53556 - Accessibility: Accessibility Inspector: MAS40B: Group items are not defined under its parent scroll area in 'Startup' window.
Summary: Accessibility: Accessibility Inspector: MAS40B: Group items are not defined u...
Status: CLOSED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Accessibility (show other bugs)
Version: 6.3 (15.1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: iain
URL:
Depends on:
Blocks:
 
Reported: 2017-03-20 14:33 UTC by Ramya Sri Narasinga
Modified: 2017-10-07 05:52 UTC (History)
1 user (show)

Tags: Accessibility,Wipro,A11yMAS,Xamarin-Studio,MAS40B;Obsolete
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED INVALID

Description Ramya Sri Narasinga 2017-03-20 14:33:49 UTC
Testing Environment: 
macOS Sierra v 10.12.3
Xamarin v6.3 (Build 731)

Repro Steps:
1. Launch Xamarin Studio.
2. Turn on Voiceover.
3. Using Accessibility Inspector, observe how 'Acquaint', 'Sport' ...etc group items are defined under the scroll area.
4. Observe VO behaviour for the same. 

Expected Behavior:
'Acquaint', 'Sport' ...etc group should be properly defined under the parent scroll area.

Actual Behavior:
'Acquaint', 'Sport' ...etc groups are not defined properly. Unable to focus using voiceover too.

Voiceover Behavior:
Unable to navigate using VO. Voiceover says as 'Empty scroll area...'. Once interaction starts, VO says, 'Empty Content Scroll area...'

User Impact:
Users relying on voiceover may miss accessing important info under the scroll area.

Suggested Fix:
Define the group elements properly under the scroll area.

Repro Video:

Please find the attachments in below link;

https://microsoft-my.sharepoint.com/personal/v-glvela_microsoft_com/_layouts/15/guestaccess.aspx?guestaccesstoken=HSHUiTlMEyqSXvzhkh52m0A1lyPgc2WmVAAUbI2U%2bZ4%3d&folderid=2_1de3c67a0c54a4b92a4bbf5a322aff0bd&rev=1
Comment 1 iain 2017-09-08 17:28:20 UTC
This bug isn't valid anymore as that screen has completely changed
Comment 2 Ramya Sri Narasinga 2017-10-07 05:52:41 UTC
Since the feature is no more available to check, closing the bug and adding the tag 'obsolete'