Bug 53547 - Accessibility: Accessibility Inspector: MAS40B: List items in "Toolbox" pad is missing a valid "Role" property.
Summary: Accessibility: Accessibility Inspector: MAS40B: List items in "Toolbox" pad i...
Status: RESOLVED DUPLICATE of bug 56632
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Accessibility (show other bugs)
Version: 6.3 (15.1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: iain
URL:
Depends on:
Blocks:
 
Reported: 2017-03-20 14:01 UTC by Ramya Sri Narasinga
Modified: 2018-05-21 10:33 UTC (History)
1 user (show)

Tags: Accessibility,Wipro,A11yMAS,Xamarin-Studio,MAS40B;FalseDuplicate,ParentBugActive
Is this bug a regression?: ---
Last known good build:


Attachments
C&E guidlines (81.50 KB, application/x-ole-storage)
2018-04-24 10:42 UTC, Ramya Sri Narasinga
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 56632

Description Ramya Sri Narasinga 2017-03-20 14:01:30 UTC
Testing Environment: 
macOS Sierra v 10.12.3
Xamarin v6.3 (Build 731)

Repro Steps:
1. Launch Xamarin Studio.
2. Open an existing file or create a new project.
3. Goto project.droid (or any available project) -->app.xaml.cs (or any file).
4. Goto 'View --> Pads --> Toolbox' menu pane.
5. In toolbox pane, check for "AXType" property for list items using Accessibility Inspector.
6. Observe VO behavior for the same.

Expected Behavior:
'List items  should have a valid "Role" property.

Actual Behavior:
'List items doesnt have a valid role property. Role is 'AXUnknown'.

Voiceover Behavior:
Voiceover doesn't read anything about the separator. There is just an empty navigation without any information being announced regarding the separators.

User Impact:
When role is empty, its type cant be identified. Voiceover wont read the element's role and label when it is focused. Loss of info to the users.

Suggested Fix:
Update the 'accessibilityRole' property accordingly.

Repro Video:

Please find the attachments in below link;

https://microsoft-my.sharepoint.com/personal/v-glvela_microsoft_com/_layouts/15/guestaccess.aspx?guestaccesstoken=teDyLsfrDe6Gz0jF7l0jpbkm%2bhi53KpTXyygvmV65eE%3d&folderid=2_1ab14de7f61334d7a9176aa9f5248f869&rev=1
Comment 1 iain 2017-05-26 11:33:24 UTC

*** This bug has been marked as a duplicate of bug 56632 ***
Comment 2 Ramya Sri Narasinga 2018-04-24 10:42:28 UTC
Created attachment 26272 [details]
C&E guidlines
Comment 3 Ramya Sri Narasinga 2018-04-24 10:45:20 UTC
As the parent bug (bug 56632)is in confirmed state, this bug is currently not actionable to us. Hence reassigning to you, please assign back to us once parent bug is ready for verification.
Please find the attached new guidance from the C&E Management Team.