Bug 53481 - The threadpool crashes on XS CI
Summary: The threadpool crashes on XS CI
Status: RESOLVED DUPLICATE of bug 53865
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Highest blocker
Target Milestone: 15.2
Assignee: Ludovic Henry
URL:
: 53802 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-17 18:23 UTC by Rodrigo Kumpera
Modified: 2017-03-24 15:41 UTC (History)
8 users (show)

See Also:
Tags: 2017-02
Is this bug a regression?: ---
Last known good build:


Attachments

Description Rodrigo Kumpera 2017-03-17 18:23:59 UTC
From the 2017-02 XS lane. In this build: https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=4354&host_id=387&revision_id=868542

The test-mdaddins-monodroid step has the following failures:

2) ThenTheSessionIsEnded (MonoDevelop.MonoDroid.Tests.DebuggerTests.MonoDroidDebuggerSessionTests.ListeningSession.GivenAProcessThatEndsUnexpectantly.ThenTheSessionIsEnded)

Results saved as /Users/builder/data/lanes/4354/8c1e7cfc/source/md-addins/TestResult_MonoDevelop.MonoDroid.Tests.dll.log.
2017-03-13 13:04:36.906 mono64[46263:37625631] error: mono_os_mutex_trylock: pthread_mutex_trylock failed with "Invalid argument" (22)
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.ThreadPool.RequestWorkerThread () [0x00006] in <3aefa6b9fd864567bced48ddb29ed320>:0
  at System.Threading.ThreadPoolWorkQueue.EnsureThreadRequested () [0x0001f] in /private/tmp/source-mono-2017-02/bockbuild-2017-02/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/threading/threadpool.cs:620

Native stacktrace:

	0   mono64                              0x000000010cb634d6 mono_handle_native_crash + 278
	1   libsystem_platform.dylib            0x00007fff899e652a _sigtramp + 26
	2   ???                                 0x000070000214eb60 0x0 + 123145337236320
	3   libsystem_c.dylib                   0x00007fff87b636df abort + 129
	4   libxammac.dylib                     0x000000011969c670 _ZL12log_callbackPKcS0_S0_iPv + 64
	5   mono64                              0x000000010cd4fdb0 monoeg_g_log + 208
	6   mono64                              0x000000010cc87948 mono_coop_mutex_lock + 120
	7   mono64                              0x000000010cc879c5 mono_threadpool_worker_enqueue + 53
	8   mono64                              0x000000010cc8635b ves_icall_System_Threading_ThreadPool_RequestWorkerThread + 539
	9   ???                                 0x0000000113020133 0x0 + 4613865779
Comment 1 Marek Safar 2017-03-22 11:11:22 UTC
Ludovic, any update on this? It happens with master on jenkins randomly too
Comment 2 Ludovic Henry 2017-03-22 13:39:07 UTC
I could never reproduce with monodevelop, but I will take a look again.

Would you have a link to where it happens on Jenkins too?
Comment 3 Ludovic Henry 2017-03-23 17:12:56 UTC
*** Bug 53802 has been marked as a duplicate of this bug. ***
Comment 4 Sebastien Pouliot 2017-03-24 14:57:25 UTC
Bug #53802 (marked as duplication) is blocking QA from running automation tests on their bots and those are needed to accept 2017-02 in xamarin-macios.
Comment 5 Ludovic Henry 2017-03-24 15:41:31 UTC

*** This bug has been marked as a duplicate of bug 53865 ***

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.