Bug 53476 - Referencing netstandard libraries cause The "ConvertPdbToMdb" task failed unexpectedly compile error
Summary: Referencing netstandard libraries cause The "ConvertPdbToMdb" task failed une...
Status: RESOLVED DUPLICATE of bug 53474
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 10.4 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-17 18:01 UTC by John Miller [MSFT]
Modified: 2017-03-19 18:29 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: No
Last known good build:


Attachments
Example Project (17.47 KB, application/zip)
2017-03-17 18:01 UTC, John Miller [MSFT]
Details

Description John Miller [MSFT] 2017-03-17 18:01:31 UTC
Created attachment 20444 [details]
Example Project

**Overview:**

Referencing a netstandard project in VS 2017 (the new .csproj format) causes a build error. 
 
**Steps to Reproduce:** 

1. Build the attached iOS project in VS 2017.


**Actual Results:**

Build Error: 

The "ConvertPdbToMdb" task failed unexpectedly.
Pdb2Mdb.PortablePdbNotSupportedException: Portable PDB 'c:\users\johmil\documents\visual studio 2017\Projects\NetStandardTest\ClassLibrary1\obj\Debug\netstandard1.6\ClassLibrary1.pdb' can't be converted to mdb. Consider setting the project 'DebugType' property to 'Full'.
   at Pdb2Mdb.Converter.Convert(String filename) in C:\d\lanes\4368\73f58d6d\source\xamarinvs\src\MSBuild\Xamarin.iOS.Tasks\Pdb2mdb\Driver.cs:line 43
   at Xamarin.iOS.Tasks.ConvertPdbToMdb.Execute() in C:\d\lanes\4368\73f58d6d\source\xamarinvs\src\MSBuild\Xamarin.iOS.Tasks\Tasks\ConvertPdbToMdb.cs:line 26
   at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
   at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__26.MoveNext()	NetStandardTest	C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.After.targets	83	


 
**Expected Results:**

 No build errors. 
 
**Build Date & Platform:**

 Microsoft Visual Studio Enterprise 2017
Version 15.0.26228.4 D15RTWSVC
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Xamarin   4.3.0.784 (73f58d6)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android SDK   7.1.0.41 (9578cdc)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK   10.4.0.123 (35d1ccd)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

**Regresion status:**

This does not appear to be a regression. 
 
**Additional Information:**

This seems related to the new portable PDB files being used in these project types.
Comment 3 Timothy Risi 2017-03-19 18:29:58 UTC

*** This bug has been marked as a duplicate of bug 53474 ***

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 53476 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: