Bug 53458 - [Xamarin-Studio] Accessibility: MAS40B:OSX: 'XPath Scope' widgets are missing accessibility attributes
Summary: [Xamarin-Studio] Accessibility: MAS40B:OSX: 'XPath Scope' widgets are missing...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Accessibility (show other bugs)
Version: 6.3 (15.1)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 15.6
Assignee: iain
URL:
Depends on:
Blocks:
 
Reported: 2017-03-17 15:12 UTC by Naveen Katakam
Modified: 2017-10-05 16:21 UTC (History)
2 users (show)

See Also:
Tags: Accessibility,A11yMAS,Wipro,MAS40B,Xamarin-Studio
Is this bug a regression?: ---
Last known good build:


Attachments

Description Naveen Katakam 2017-03-17 15:12:16 UTC
Test Environment:

Repro Steps:
"1. Launch Xamarin Studio.
2. Navigate to 'Xamarin Studio Community--> Preferences' menu and hit Enter key to open its window.
3. Goto Source code --> Code Formatting --> XML document' pane.
4. In RHS of the pane, goto 'XML Format' tab menu item and hit enter.
5. Goto 'Advanced Settings --> Add --> Xpath Scope group'.
6. Using Accessibility Inspector, check if its defined completely."


Actual Result:
Xpath Scope' is defined incompletely. Only top level group is present. The other UI elements are missing.

Expected Result:
"Xpath Scope' should be defined with proper label/title as a group containing the following;
1. 'XPath Scope' text.
2. 'XPath Scope' edit field.
3. 'Add XPath Scope' button."

User Impact:
User will not be able to navigate properly using keyboard and also using voiceover. Voiceover will skip the other elements.

Repro Video:
Please download repro video from below location.
https://microsoft-my.sharepoint.com/personal/v-glvela_microsoft_com/_layouts/15/guestaccess.aspx?guestaccesstoken=rWi7EQQAWks%2b4X2%2fWGjy6ADL4dD%2faiQ3D98uoD8Q%2fho%3d&folderid=2_17402726b8ef9461f9a1da8cb36c51506&rev=1
Comment 1 iain 2017-05-26 13:25:56 UTC

*** This bug has been marked as a duplicate of bug 53624 ***
Comment 2 Ramya Sri Narasinga 2017-09-25 12:29:10 UTC
This issue is not fixed on the below provided build:
Visual Studio Community 2017 for Mac (Preview)
Version 7.3 Preview (7.3 build 510)
Hence reactivating this bug.
Comment 3 iain 2017-09-30 08:16:29 UTC
Incorrectly marked as duplicate of 53624
Comment 4 xamarin-release-manager 2017-10-05 16:21:41 UTC
Fixed in version 7.4.0.258 (master)

Author: iain holmes
Commit: 5c20e4ab22212bbc10cfc14ae7855e8f865b344d (mono/monodevelop)

Note You need to log in before you can comment on or make changes to this bug.