Bug 53430 (vs-504797) - No error shown when tests fail to load
Summary: No error shown when tests fail to load
Status: RESOLVED FIXED
Alias: vs-504797
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: 7.0 (VSforMac)
Hardware: PC Mac OS
: Highest normal
Target Milestone: 15.6
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2017-03-17 00:56 UTC by Mikayla Hutchinson [MSFT]
Modified: 2018-01-12 09:29 UTC (History)
3 users (show)

Tags: vs-sync
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (16.14 KB, application/zip)
2017-03-17 15:06 UTC, David Karlaš
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2017-03-17 00:56:18 UTC
When tests fail to load due to a missing dependency (e.g. referenced project not set to local copy), there is no error displayed or logged anywhere at all.
Comment 1 David Karlaš 2017-03-17 15:06:51 UTC
Created attachment 20437 [details]
sample project

I added sample project with unit test project where I disabled local copy, but everything keeps working fine.

Can you give more details on how to reproduce this?
Comment 2 Mikayla Hutchinson [MSFT] 2017-03-17 20:16:05 UTC
Check out https://github.com/mono/t4 and disable local copy on the Mono.TextTemplating.Tests->Mono.TextDemplating reference before building.
Comment 3 David Karlaš 2017-03-20 10:04:53 UTC
I can reproduce this. In Unit tests pad test project has 0 unit tests and no errors.(It should show error instead)
Comment 4 David Karlaš 2017-06-02 13:48:02 UTC
I'm moving this to 15.4 since there I will be implementing https://github.com/Microsoft/vstest and will address this problem there
Comment 5 David Karlaš 2017-07-06 07:55:48 UTC
Switch to vstest was moved to 15.5 hence so is bug
Comment 6 David Karlaš 2017-09-14 12:35:56 UTC
VSTest integration was finished for 15.5, but NUnit projects continue to use existing logic for now, maybe we change that for 15.6 to also use VSTest, hence moving to 15.6 milestone.