Bug 53361 - error in xsp4
Summary: error in xsp4
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies (show other bugs)
Version: 4.6.0 (C8)
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-15 14:43 UTC by Roman
Modified: 2017-09-01 09:05 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Roman 2017-03-15 14:43:05 UTC
I have asp.net mvc web site with razor engine and WCF service. So I run xsp4 --port:80 from command line and after open my site in web browser I see error in command line output

Handling exception type NullReferenceException
Message is Object reference not set to an instance of an object
IsTerminating is set to True
Object reference not set to an instance of an object
  at System.ServiceModel.Dispatcher.ListenerLoopManager.ProcessRequest (System.ServiceModel.Channels.IReplyChannel reply, System.ServiceModel.Channels.RequestContext rc) [0x0005c] in <8cdac92fdd4b495ba10570db10926ad4>:0 
  at System.ServiceModel.Dispatcher.ListenerLoopManager.TryReceiveRequestDone (System.IAsyncResult result) [0x0001a] in <8cdac92fdd4b495ba10570db10926ad4>:0 
  at (wrapper managed-to-native) System.Runtime.Remoting.Messaging.AsyncResult:Invoke (System.Runtime.Remoting.Messaging.AsyncResult)
  at System.Runtime.Remoting.Messaging.AsyncResult.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem () [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Threading.ThreadPoolWorkQueue.Dispatch () [0x00096] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback () [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0 

And what can I resolve this problem?

Note You need to log in before you can comment on or make changes to this bug.