Bug 53276 - Deploy to emulator takes forever
Summary: Deploy to emulator takes forever
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.1 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2017-03-13 11:19 UTC by anton.duzenko@gmail.com
Modified: 2017-10-04 16:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build log (1.20 MB, text/plain)
2017-03-13 11:19 UTC, anton.duzenko@gmail.com
Details
Screenshot (944.74 KB, image/png)
2017-03-13 11:19 UTC, anton.duzenko@gmail.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description anton.duzenko@gmail.com 2017-03-13 11:19:16 UTC
Created attachment 20286 [details]
Build log

I can no longer run any app on any emulator from VS2015.
Steps to reproduce:
1 - create a new cross platform app (Xamarin Forms + PCL)
2 - create a new emulator Intel HAXM + Android 4.4
Attempt to run the app on the emulator.
Deploy takes forever and the app does not start.
Comment 1 anton.duzenko@gmail.com 2017-03-13 11:19:37 UTC
Created attachment 20287 [details]
Screenshot
Comment 2 Prashant [MSFT] 2017-06-23 08:19:06 UTC
Is it an issue with particular emulator?
Could you share the ADB logs from the emulator? It will help us to troubleshoot the issue
Comment 3 Jon Douglas [MSFT] 2017-10-04 16:30:50 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!

Additionally your issue is in the build log:

2>Using fast dev path: /storage/sdcard/Android/data/com.companyname.App1/files/.__override__
2>Synchronizing assemblies...
2>Fast dev didn't succeed, trying another location...
2>Getting installation path...
2>Using fast dev path: /data/data/com.companyname.App1/files/.__override__
2>Synchronizing assemblies...
2> Deployment failed
2>Xamarin.AndroidTools.AndroidDeploymentException: FastDevDirectoryCreationFailed
2>   at Xamarin.AndroidTools.AndroidDeploySession.WaitForRemoteDirCreation(String destinationPath, CancellationToken token)
2>   at Xamarin.AndroidTools.AndroidDeploySession.<InstallAssemblies>c__asyncA.MoveNext()
2>--- End of stack trace from previous location where exception was thrown ---
2>   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
2>   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
2>   at Xamarin.AndroidTools.AndroidDeploySession.<FastDevAsync>c__async8.MoveNext()
2>--- End of stack trace from previous location where exception was thrown ---
2>   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
2>   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
2>   at System.Runtime.CompilerServices.TaskAwaiter.GetResult()
2>   at Xamarin.AndroidTools.AndroidDeploySession.<RunAsync>c__async2.MoveNext()
2>--- End of stack trace from previous location where exception was thrown ---
2>   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
2>   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
2>   at Xamarin.AndroidTools.AndroidDeploySession.<RunLoggedAsync>c__async1.MoveNext()
2>FastDevDirectoryCreationFailed

Try disabling fast deployment and seeing if that works.