Bug 53275 - IProvideValueTarget TargetProperty always null
Summary: IProvideValueTarget TargetProperty always null
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.4
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-13 10:02 UTC by workgroupengineering
Modified: 2017-07-13 07:56 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description workgroupengineering 2017-03-13 10:02:23 UTC

    
Comment 1 Paul DiPietro [MSFT] 2017-03-13 14:05:46 UTC
This bug report is empty and thus being closed. If there is a bug, please reopen with relevant information and a reproduction.
Comment 2 workgroupengineering 2017-03-13 16:32:36 UTC
When in custom MarkupExtension you using IProvideValueTarget to get TargetProperty is always null, Because in the source code at https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Xaml/XamlServiceProvider.cs#L17 you always setted null the targetProperty parameter of XamlServiceProvider constructor.
Comment 3 workgroupengineering 2017-03-14 09:44:31 UTC
I have push PR https://github.com/xamarin/Xamarin.Forms/pull/814
Comment 4 Stephane Delcroix 2017-04-07 08:03:06 UTC
merged PR https://github.com/xamarin/Xamarin.Forms/pull/847

should be fixed in 2.3.5-pre1