This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 53275 - IProvideValueTarget TargetProperty always null
Summary: IProvideValueTarget TargetProperty always null
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.4
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-13 10:02 UTC by workgroupengineering
Modified: 2017-04-07 08:03 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description workgroupengineering 2017-03-13 10:02:23 UTC

    
Comment 1 Paul DiPietro 2017-03-13 14:05:46 UTC
This bug report is empty and thus being closed. If there is a bug, please reopen with relevant information and a reproduction.
Comment 2 workgroupengineering 2017-03-13 16:32:36 UTC
When in custom MarkupExtension you using IProvideValueTarget to get TargetProperty is always null, Because in the source code at https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Xaml/XamlServiceProvider.cs#L17 you always setted null the targetProperty parameter of XamlServiceProvider constructor.
Comment 3 workgroupengineering 2017-03-14 09:44:31 UTC
I have push PR https://github.com/xamarin/Xamarin.Forms/pull/814
Comment 4 Stephane Delcroix 2017-04-07 08:03:06 UTC
merged PR https://github.com/xamarin/Xamarin.Forms/pull/847

should be fixed in 2.3.5-pre1

Note You need to log in before you can comment on or make changes to this bug.