Bug 53215 - Master Details Hamburger Menu Icon not displayed on UWP since V2.3.2.127
Summary: Master Details Hamburger Menu Icon not displayed on UWP since V2.3.2.127
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jimmy [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-10 07:22 UTC by Richard Woollcott
Modified: 2017-07-12 12:54 UTC (History)
3 users (show)

Tags: bug, uwp, masterdetailpage
Is this bug a regression?: Yes
Last known good build: 2.3.2.127


Attachments
Hamburger Menu Icon displayed (25.83 KB, image/png)
2017-03-10 07:22 UTC, Richard Woollcott
Details
Attached IDE logs (1.95 KB, application/x-zip-compressed)
2017-07-12 12:53 UTC, Saurabh Paunikar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Richard Woollcott 2017-03-10 07:22:23 UTC
Created attachment 20264 [details]
Hamburger Menu Icon displayed

When using a Master Detail page on UWP Windows 10 Desktop the Hamburger Menu icon is no longer displayed when navigating to a Detail Page.

I am using the Xamarin.Forms MasterDetail Navigation Sample from to identify and reproduce the problem:-
https://github.com/xamarin/xamarin-forms-samples/tree/master/Navigation/MasterDetailPage

This last worked in Xamarin.Forms V2.3.2.127 - I have attached a screenshot of this showing the Hamburger Icon which is not displayed on the newer versions.

I have tested these versions and all fail:-
2.3.3.168
2.3.3.175
2.3.3.180
2.3.3.193
2.3.4.211-pre3 

I am using Visual Studio Professional 2015 Update 3 on Windows 10, Version 10.0.14393 Build 14393

Please can you consider this for inclusion in the next release since the Master Detail forms the core navigation of my app and targeting Windows 10 desktop is critical.

Thanks, Richard
Comment 1 Jimmy [MSFT] 2017-03-10 16:38:57 UTC
Thank you for reporting this! I can reproduce the issue with the MasterDetailPage Forms sample and this does appear to be a regression. I am confirming this report so the team can investigate further.

### Regression Test
Forms 2.3.4.-pre4   BAD
Forms 2.3.3.180     BAD
Forms 2.3.1.127     GOOD
Comment 2 Jimmy [MSFT] 2017-03-10 16:59:25 UTC
Just as a quick follow up, I tested with a master branch build of Forms and the issue seems resolved due to a change that makes IsPresented intentionally not work in split mode on UWP desktop [1] so the master page is not hidden and there is no need for the menu button.

You can change the MasterBehavior to Popover instead and it will restore similar functionality. This issue doesn't seem to affect the Popover behavior and it works as expected on Forms 2.3.3.193 and 2.3.4-pre4.

[1] https://github.com/xamarin/Xamarin.Forms/pull/707
Comment 3 Richard Woollcott 2017-03-10 19:36:53 UTC
Thanks for the quick response Jimmy much appreciated. I think the bug can be resolved.

So when I changed the sample app to V2.3.4.-pre4 and then edited the MasterDetailPage to explicitly set the MasterBehavior to Popover it worked as you described.

The Sample as presented kinda doesn't really work too well out of the box on UWP with the later versions of Forms since without setting the MasterBehavior the master pane disappears when an item is selected and no hamburger icon is displayed. Explicitly setting the MasterBehaviour to Popover resolves this. And when setting the MasterBehavior to Split an exception is thrown because IsPresented is set in the MainPage OnItemSelected method.

Maybe some comments in the sample source code or ReadMe.MD could help. I appreciate it's probably a bit of a niche scenario.

Thanks,
Richard
Comment 4 Jimmy [MSFT] 2017-03-28 17:07:40 UTC
I'll go ahead and resolve this report, and I've created a PR in the samples repo for a workaround in the meantime: https://github.com/xamarin/xamarin-forms-samples/pull/178
Comment 5 Saurabh Paunikar 2017-07-12 12:53:58 UTC
Created attachment 23497 [details]
Attached IDE logs

This issue doesn't exist anymore, hence marking it as Verified

Screencast link : https://www.screencast.com/t/Xdc4mrujR0ok

Environment info : https://gist.github.com/saurabh-paunikar/13e01e9b1600e32a06d2a2528163c77c 

Verfied on 2.3.5.256-pre6