Bug 53058 - Generator allows native enum in native delegates return value
Summary: Generator allows native enum in native delegates return value
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: 15.2
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2017-03-04 18:24 UTC by Sebastien Pouliot
Modified: 2017-04-27 12:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Pouliot 2017-03-04 18:24:34 UTC
New tests [1] from PR1751 are failing because of this.

2017-02-23 00:32:57.212 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DNSComparator.Invoke has a [Native] enum parameter in its signature: Foundation.NSComparisonResult 
2017-02-23 00:32:57.214 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DNSComparator.EndInvoke has a [Native] enum parameter in its signature: Foundation.NSComparisonResult 
2017-02-23 00:32:57.418 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DFuncArity2V2.Invoke has a [Native] enum parameter in its signature: MediaPlayer.MPRemoteCommandHandlerStatus 
2017-02-23 00:32:57.427 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DFuncArity2V2.EndInvoke has a [Native] enum parameter in its signature: MediaPlayer.MPRemoteCommandHandlerStatus 
2017-02-23 00:32:57.431 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DFuncArity3V0.Invoke has a [Native] enum parameter in its signature: Foundation.NSComparisonResult 
2017-02-23 00:32:57.432 introspection[64521:30048883] [FAIL] ObjCRuntime.Trampolines+DFuncArity3V0.EndInvoke has a [Native] enum parameter in its signature: Foundation.NSComparisonResult 
2017-02-23 00:32:57.515 introspection[64521:30048883] 	[FAIL] iOSApiPInvokeTest.MonoPInvokeCallback :   6 errors found in 559 native delegate validated: 

[1] https://github.com/xamarin/xamarin-macios/pull/1751#issuecomment-281899688
Comment 1 Sebastien Pouliot 2017-03-05 04:09:53 UTC
PR master https://github.com/xamarin/xamarin-macios/pull/1823
Comment 3 Sebastien Pouliot 2017-04-14 13:43:38 UTC
the unit tests that failed (in description) are now working fine

see `test-sim-introspection` in https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=4691&host_id=392&revision_id=882405
Comment 4 Roshan Mankani 2017-04-27 12:20:26 UTC
Hello @Sebastien Pouliot can you provide steps or information for verify the bug.