Bug 52874 - Editor text entry gets messed up
Summary: Editor text entry gets messed up
Status: CONFIRMED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Mac (show other bugs)
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
URL:
: 58575 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-27 22:12 UTC by Stephen Shaw
Modified: 2017-09-11 17:26 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Current release (73.19 KB, image/png)
2017-02-27 22:12 UTC, Stephen Shaw
Details
Current master (26.73 KB, image/png)
2017-02-27 22:14 UTC, Stephen Shaw
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 52874 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
CONFIRMED

Description Stephen Shaw 2017-02-27 22:12:19 UTC
Created attachment 20020 [details]
Current release

In the current release of Workbooks the text editor can get really confused and starts drawing text entries in the wrong places. It seems more like the backgrounds/boxes get redraw roughly in the correct place and size, but the text fields do not. I've found that cutting and pasting blocks of various sizes really triggers this. For example, create a few single line blocks such as "int x = 3;" and then add something like a class. Then take that class and paste it into the first block. The alignments should get all messed up.
Comment 1 Stephen Shaw 2017-02-27 22:14:11 UTC
Testing with the lastest master it seems the problem isn't nearly as bad in my simple test. However, it still seems to be slightly off. If you look at the screenshots you'll notice that the top border is missing/drawn over.
Comment 2 Stephen Shaw 2017-02-27 22:14:25 UTC
Created attachment 20021 [details]
Current master
Comment 3 Sandy Armstrong [MSFT] 2017-02-27 22:16:30 UTC
First screenshot is 1.1.2, second screenshot is 1.1.90 (15.1 branch, not master), btw.
Comment 4 Aaron Bockover [MSFT] 2017-02-28 15:46:24 UTC
@Stephen what version of macOS are you on?

Does this happen on all cells? Small workbooks? Large workbooks? More often in some cases than others, etc.

I have not seen anything like what your screenshots are implying.
Comment 5 Stephen Shaw 2017-02-28 18:59:23 UTC
MacOS 10.12.3
Small workbooks


I'm able to do this fairly reliably reproduce this with very little code. I think the "trigger" is copying larger pieces of code and pasting them into previous smaller blocks of code.

I've been trying to reproduce this again today, but haven't been very successful. I have seen this in the past on several occasions. I'll continue to try and keep an eye out for this as I use workbooks.
Comment 6 Stephen Shaw 2017-02-28 20:24:00 UTC
Ok, I was able to partly reproduce this with 1.1.90. Here is a screencast
https://www.screencast.com/t/jr4d8r33
Comment 7 Bojan Rajkovic [MSFT] 2017-08-21 15:27:49 UTC
*** Bug 58575 has been marked as a duplicate of this bug. ***