Bug 52718 - Agent never connected
Summary: Agent never connected
Status: RESOLVED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Agent: iOS (show other bugs)
Version: 1.1.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
URL:
Depends on:
Blocks:
 
Reported: 2017-02-23 19:52 UTC by Chris Hardy [MSFT]
Modified: 2017-10-02 17:42 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Chris Hardy [MSFT] 2017-02-23 19:52:37 UTC
Whilst trying to repro another issue, the agent never connected to the simulator: https://screencast.com/t/iFTh3REub6O

https://gist.github.com/chrisntr/ccc360de57e8e2e93d37b2ddf8c6b257
Comment 1 Sandy Armstrong [MSFT] 2017-02-23 20:28:29 UTC
Is the simulator frozen? I've seen the iOS sim freeze and need restarting before anything works with it.

Does quitting the simulator and trying to open the workbook again cause it the sim to launch, load the app, and connect as expected?
Comment 2 Chris Hardy [MSFT] 2017-02-23 20:35:48 UTC
The simulator seemed fine and just closing and re-opening Workbooks (leaving the Simulator as is) seemed to get things up and running again. So not too sure without it happening frequently if there's too much that can be done here.
Comment 3 Sandy Armstrong [MSFT] 2017-02-23 20:39:11 UTC
If quitting and reopening Workbooks fixed it, it's more likely to be a bug with us, then. Will poke around.
Comment 4 Aaron Bockover [MSFT] 2017-09-11 17:18:05 UTC
We've done quite a bit of work in this area since the last activity on this bug. Would you mind testing with the latest 1.3 in the Beta channel and confirm if this is still an issue?
Comment 5 Aaron Bockover [MSFT] 2017-10-02 17:42:57 UTC
Closing due to no response in a few weeks.

Note You need to log in before you can comment on or make changes to this bug.