Bug 52577 - System.Data.SqlClient.SqlParameter does not contain a definition for TypeName
Summary: System.Data.SqlClient.SqlParameter does not contain a definition for TypeName
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Data (show other bugs)
Version: 4.6.0 (C8)
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-02-16 16:55 UTC by Sean Rowe
Modified: 2017-10-27 12:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sean Rowe 2017-02-16 16:55:41 UTC
Though the source code seems to have TypeName defined, it does not seem to be available after mono is compiled. I've even downloaded the source code and recompiled to make sure it wasn't something with the binary I downloaded for Ubuntu.
Comment 1 Egorbo 2017-02-23 17:35:21 UTC
Reproduced. The property is not available but can be called via Reflection:
typeof(SqlParameter).GetProperty("TypeName").GetValue(param, null);

So looks like the Reference assemblies for this Profile doesn't have it defined.

mono\external\binary-reference-assemblies\v4.5\System.Data.dll
Comment 2 Marek Safar 2017-02-23 18:26:18 UTC
As a workaround update your .net target version to framework to 4.6
Comment 3 Marek Safar 2017-10-27 12:03:18 UTC
Already fixed in master