Bug 52576 - A very long app name makes the android debugger fail to start
Summary: A very long app name makes the android debugger fail to start
Status: RESOLVED DUPLICATE of bug 44420
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 7.1 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-16 16:29 UTC by Jerome Laban
Modified: 2017-06-27 15:03 UTC (History)
2 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44420

Description Jerome Laban 2017-02-16 16:29:23 UTC
When an application has a very long package name, the debugger fails to start with this message:

    Couldn't connect to logcat, GetProcessId returned: 0

The reason why this happens is not clear.
Comment 1 Tom Opgenorth 2017-06-26 17:22:09 UTC
Thank you for taking the time to submit the bug. We are unable to reproduce this issue (Visual Studio for Mac will not let me create a project with a very long project name). Please attach a reproduction to the bug by starting with a clean Xamarin.Android project and adding just the code necessary to demonstrate the issue.
Comment 2 Tom Opgenorth 2017-06-27 15:03:27 UTC
Found another bug that already details this issue, along with some more details.

*** This bug has been marked as a duplicate of bug 44420 ***