Bug 52539 - [iOS]Apps failed to launch on device with an MT0010 error if bundleidentifier is not set
Summary: [iOS]Apps failed to launch on device with an MT0010 error if bundleidentifier...
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 10.4 (C9)
Hardware: PC Mac OS
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-15 20:36 UTC by GouriKumari
Modified: 2017-10-30 19:14 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 52539 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description GouriKumari 2017-02-15 20:36:39 UTC
## Steps to reproduce:
Download and execute RosyWriter sample on an iOS device.

## Actual Behaviour:
error MT0010: Could not parse the command line arguments: System.AggregateException: One or more errors occurred. ---> Xamarin.Launcher.LauncherException: Unknown command line argument: '/Users/gourikumari/ios-samples/RosyWriter/bin/iPhone/Debug/RosyWriter.app'
   --- End of inner exception stack trace ---
  at Xamarin.Launcher.Driver.Main2 (System.String[] args) [0x0085b] in <5938353ff0f5443696cc82980fdf17ed>:0 
---> (Inner Exception #0) error MT0018: Unknown command line argument: '/Users/gourikumari/ios-samples/RosyWriter/bin/iPhone/Debug/RosyWriter.app'<---

##Logs:
Build Log: https://gist.github.com/GouriKumari/dd6c1559173bd29032f58c116fa44ac6
Application Output: https://gist.github.com/GouriKumari/a21a6ee335e2be36416e89dbd87cf0e7

##Supplemental Info: 
This issue occurred because the bundle identifier wasn't set in Info.plist and provisioning profile in iOS bundle signing was showing Unknown(). 
Once a bundle identifier was added, correct provisioning profile populated in iOS bundle signing, error mentioned in actual behaviour disappeared and app launched on device. 

This issue occurs in only in apps written with old templates.

With new templates a warning is generated that bundle identifier is not set, https://gist.github.com/GouriKumari/daf6d3a686ed227cfe21cbb80f1fb704

##  Test Logs:
Build Log: https://gist.github.com/GouriKumari/dd6c1559173bd29032f58c116fa44ac6
Application Output: https://gist.github.com/GouriKumari/a21a6ee335e2be36416e89dbd87cf0e7
Test Env: https://gist.github.com/GouriKumari/6bc172dadaf21d452d2a640dbd377f24