Bug 52466 - [UWP Desktop Mode] MasterBehavior Default value doesn't work for MasterDetailPage
Summary: [UWP Desktop Mode] MasterBehavior Default value doesn't work for MasterDetail...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-02-13 08:15 UTC by Anubhav Ranjan
Modified: 2017-07-12 12:56 UTC (History)
4 users (show)

See Also:
Tags: mdp uwp desktop masterbehavior
Is this bug a regression?: ---
Last known good build:


Attachments
Attached IDE logs (1.97 KB, application/x-zip-compressed)
2017-07-12 11:04 UTC, Aman Dharwal
Details
Attached IDE logs (1.95 KB, application/x-zip-compressed)
2017-07-12 12:55 UTC, Saurabh Paunikar
Details

Description Anubhav Ranjan 2017-02-13 08:15:03 UTC
Following the sample code provided in Docs https://developer.xamarin.com/guides/xamarin-forms/user-interface/navigation/master-detail-page/

It seems like in the absence of the property MasterBehavior, the App in UWP (Desktop Mode), doesn't show the Hamburger Icon itself. Also, the default value for MasterBehavior declared explicitly doesn't help. On tapping any of the Menu Items from the left pane, the User won't have any way to navigate back.

Setting it to MasterBehavior="Popover" or "Split" makes it work.

Sample:
=======
https://developer.xamarin.com/samples/xamarin-forms/Navigation/MasterDetailPage

Demo:
======
https://www.screencast.com/t/NuPbL4YLPPCP


Version Info:
==============

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Architecture and Modeling Tools   00322-90150-04767-AA280
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Microsoft Visual Studio Tools for Applications 2015   00322-90150-04767-AA280
Microsoft Visual Studio Tools for Applications 2015

Visual Basic 2015   00322-90150-04767-AA280
Microsoft Visual Basic 2015

Visual C# 2015   00322-90150-04767-AA280
Microsoft Visual C# 2015

Visual C++ 2015   00322-90150-04767-AA280
Microsoft Visual C++ 2015

Windows Phone SDK 8.0 - ENU   00322-90150-04767-AA280
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   7.17.00119.9
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1   14.1.21111.0
ASP.NET and Web Tools 2015.1

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Azure App Service Tools v2.9.6   14.0.21111.0
Azure App Service Tools v2.9.6

Azure Data Lake Node   1.0
This package contains the Data Lake integration nodes for Server Explorer.

Azure Data Lake Tools for Visual Studio   2.2.2100.0
Microsoft Azure Data Lake Tools for Visual Studio

Command Bus, Event Stream and Async Manager   Merq
Provides ICommandBus, IEventStream and IAsyncManager MEF services for loosely coupled Visual Studio extension components communication and integration.

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Microsoft .NET Core Tools (Preview 2)   14.1.21111.0
Microsoft .NET Core Tools (Preview 2)

Microsoft Azure Hive Query Language Service   2.2.2100.0
Language service for Hive query

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft Azure Tools   2.9
Microsoft Azure Tools for Microsoft Visual Studio 2015 - v2.9.41104.6

NuGet Package Manager   3.5.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

ToolWindowHostedEditor   1.0
Hosting json editor into a tool window

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.2.2.11 (00fa5cc)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.42 (501e63c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.3.1.8 (7beaef4)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Paul DiPietro [MSFT] 2017-05-31 20:31:24 UTC
Related to https://bugzilla.xamarin.com/show_bug.cgi?id=51236, I believe this particular issue is fixed via https://github.com/xamarin/Xamarin.Forms/pull/707 based on my testing of the app. The master pane does not disappear when selecting one of the detail pages due to the changes in that PR (where it should simply default to Split and not allow IsPresented to work when Split is active), but setting the MasterBehavior to Popover works as expected.
Comment 3 Aman Dharwal 2017-07-12 10:55:35 UTC
This issue is still reproducible, also defect https://bugzilla.xamarin.com/show_bug.cgi?id=51236 is in confirmed state, hence reopening the issue

screencast link : https://www.screencast.com/t/KOkRWQ6t2P

Environment info : https://gist.github.com/saurabh-paunikar/13e01e9b1600e32a06d2a2528163c77c
Comment 4 Aman Dharwal 2017-07-12 11:04:30 UTC
Created attachment 23493 [details]
Attached IDE logs

Diagonistic logs : https://gist.github.com/saurabh-paunikar/e4a8605b1ed2882a9e39524d250b7657
Comment 5 Saurabh Paunikar 2017-07-12 12:55:27 UTC
Created attachment 23498 [details]
Attached IDE logs

Verified this issue on latest 2.3.5.256-pre6

Screencast link : https://www.screencast.com/t/Xdc4mrujR0ok

Environment info : https://gist.github.com/saurabh-paunikar/13e01e9b1600e32a06d2a2528163c77c

Note You need to log in before you can comment on or make changes to this bug.