Bug 52400 - Missing Using in Trampoline Code for Bindings with delegates returning Bound Objects and Protocols
Summary: Missing Using in Trampoline Code for Bindings with delegates returning Bound ...
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 10.4 (C9)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-08 17:44 UTC by Bill Holmes
Modified: 2017-02-10 18:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Tests to reproduce (4.28 KB, application/zip)
2017-02-08 17:44 UTC, Bill Holmes
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 52400 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Bill Holmes 2017-02-08 17:44:54 UTC
Created attachment 19761 [details]
Tests to reproduce

Build the attached solution file.

Expected results:

Build without error

Actual results:

error CS0246: The type or namespace name `ITestProto' could not be found. Are you missing `MissingUsingInTrampoline' using directive?