Bug 52364 - IOS Build fails MT1009
Summary: IOS Build fails MT1009
Status: RESOLVED DUPLICATE of bug 52113
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-07 16:51 UTC by Paul Mace
Modified: 2017-02-14 09:37 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 52113

Description Paul Mace 2017-02-07 16:51:07 UTC
Stable build compiles and deploys without problems. Cycle 9n 1798 fails.


/Users/MacOwner/xProjects/SpinX/iOS/MTOUCH: Error MT1009: Could not copy the assembly '/Library/Frameworks/Xamarin.iOS.framework/Versions/10.4.0.97/lib/mono/Xamarin.iOS/mscorlib.dll' to '/Users/MacOwner/xProjects/SpinX/iOS/obj/iPhone/Debug/device-builds/iphone7.2-10.2.1/mtouch-cache/Link/mscorlib.dll': Access to the path "/Library/Frameworks/Xamarin.iOS.framework/Versions/10.4.0.97/lib/mono/Xamarin.iOS/mscorlib.dll.mdb" or "/Users/MacOwner/xProjects/SpinX/iOS/obj/iPhone/Debug/device-builds/iphone7.2-10.2.1/mtouch-cache/Link/mscorlib.dll.mdb" is denied. (MT1009) (SpinX.iOS)

Xamarin Studio Business
Version 6.2 (build 1798)
Installation UUID: 5bbc676b-7250-4ece-b666-d58927718b0a
Runtime:
	Mono 4.8.0 (mono-4.8.0-branch/084f912) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 408000478
Comment 1 Marius Ungureanu 2017-02-14 07:07:29 UTC
Adding Jeff to CC. This is a macios issue, right?
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-02-14 09:37:59 UTC
See https://bugzilla.xamarin.com/show_bug.cgi?id=52113#c4 for a workaround.

*** This bug has been marked as a duplicate of bug 52113 ***