Bug 52361 - OperationContext.Current.IncomingMessageProperties always null in Xamarin
Summary: OperationContext.Current.IncomingMessageProperties always null in Xamarin
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: WCF assemblies (show other bugs)
Version: 4.6.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-07 15:31 UTC by weases
Modified: 2018-03-13 11:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description weases 2017-02-07 15:31:38 UTC
I am trying to read http headers from a wcf response in a Xamarin.Android application. While the same approach works well within a console application, it turns out that in the Xamarin application calling OperationContext.Current.IncomingMessageProperties always returns null. Any idea why?

On the other hand, sending http request headers via OperationContext.Current.OutgoingMessageProperties works in both console and Xamarin application!?
Comment 1 Rodrigo Kumpera 2017-02-13 21:54:09 UTC
Hi,

Could you provide testing code that shows the issues you're having. It would greatly help us diagnose your problem.
Comment 2 Marek Safar 2018-03-13 11:07:17 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!