Bug 52345 - Process has exited, so the requested information is not available
Summary: Process has exited, so the requested information is not available
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Interop (show other bugs)
Version: master
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Ludovic Henry
URL:
Depends on:
Blocks:
 
Reported: 2017-02-07 00:02 UTC by Rodrigo Kumpera
Modified: 2017-02-08 22:37 UTC (History)
9 users (show)

Tags: 2017-02
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rodrigo Kumpera 2017-02-07 00:02:02 UTC
This is from testing Xs with master mono.

Build: https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=4284&host_id=387&revision_id=851566

This issue:

1) KillCSProxy (MonoTouch.Design.Client.ServerProcessConnectionTests.KillCSProxy)
   System.InvalidOperationException : Process has exited, so the requested information is not available.
  at System.Diagnostics.Process.get_ProcessName () [0x0002d] in /private/tmp/source-mono-master/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/System/System.Diagnostics/Process.cs:336 


On the following steps:

test-ios-client_xcode70_9.0_EN
test-ios-client_xcode71_9.1_EN	
test-ios-client_xcode72_9.2_EN	
test-ios-client_xcode8_10.0_EN	
test-ios-client_xcode82_10.2_EN	



One of the tests ends with: 

2017-01-26 19:41:23.643 mono64[10788:26506901] 
Unhandled Exception:
System.Exception: Failed to marshal the Objective-C object 0x7f934862d5d0 (type: Xamarin_Designer_Mac_DesignerDragOperationMac_MacDragImage_LayerScaleTransitionDelegate). Could not find an existing managed instance for this object, nor was it possible to create a new managed instance (because the type 'Xamarin.Designer.Mac.DesignerDragOperationMac+MacDragImage+LayerScaleTransitionDelegate' does not have a constructor that takes one IntPtr argument).
  at ObjCRuntime.Runtime.MissingCtor (System.IntPtr ptr, System.IntPtr klass, System.Type type, ObjCRuntime.Runtime+MissingCtorResolution resolution) [0x0006e] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at ObjCRuntime.Runtime.ConstructNSObject[T] (System.IntPtr ptr, System.Type type, ObjCRuntime.Runtime+MissingCtorResolution missingCtorResolution) [0x0002c] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at ObjCRuntime.Runtime.ConstructNSObject (System.IntPtr ptr, System.IntPtr klass, ObjCRuntime.Runtime+MissingCtorResolution missingCtorResolution) [0x00015] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at ObjCRuntime.Runtime.GetNSObject (System.IntPtr ptr, ObjCRuntime.Runtime+MissingCtorResolution missingCtorResolution, System.Boolean evenInFinalizerQueue) [0x00034] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at Registrar.DynamicRegistrar.GetMethodDescriptionAndObject (System.Type type, System.IntPtr selector, System.IntPtr obj, System.IntPtr& mthis) [0x00068] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at ObjCRuntime.Runtime.GetMethodAndObjectForSelector (System.IntPtr klass, System.IntPtr sel, System.IntPtr obj, System.IntPtr& mthis) [0x0000c] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
  at ObjCRuntime.Runtime.get_method_and_object_for_selector (System.IntPtr cls, System.IntPtr sel, System.IntPtr obj, System.IntPtr& mthis, System.Int32& exception_gchandle) [0x00006] in <fc5e1fa5f40e47b7ab6a305f19513423>:0 
-
Comment 1 Rodrigo Kumpera 2017-02-07 00:06:33 UTC
Sebastien,

Could those failures be due to the XI being used still on mono 4.8?
Comment 2 Sebastien Pouliot 2017-02-07 01:15:32 UTC
I doubt it. 

The code that fails seems to be executing the Mac (not the iOS simulator) and it seems to be related to the designer (not the addin). 

Even the additional stack trace is for the Mac - but looks unrelated to the first failure.

c.c. Alan who should be able to provide more context
Comment 3 Lluis Sanchez 2017-02-07 11:14:38 UTC
Reassigning.
Comment 4 Vinicius Jarina 2017-02-07 21:51:27 UTC
Hi Lluis. Not sure why was assigned to iOS Designer :-)

This seem a bug related with the latest Mono (4.9)

And is quite simple to repro.

* Install mono 4.9 (https://bosstoragemirror.blob.core.windows.net/wrench/mono-master/b3/b37bb1736d1c4fcd9cbf8a31416697e263d108cc/MonoFramework-MDK-4.9.0.1709.macos10.xamarin.universal.pkg)

* Create a console Application:

 https://gist.github.com/viniciusjarina/c263216973e32b04e20a4faa4cb68c1d

* Try to run ;-) 

https://screencast.com/t/hWiGMAYscbk7
Comment 5 Ludovic Henry 2017-02-08 22:37:33 UTC
This is fixed with https://github.com/mono/mono/pull/4351