This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 52259 - XA depends on random source file from the mono tree that is gone on master
Summary: XA depends on random source file from the mono tree that is gone on master
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2017-02-02 17:57 UTC by Rodrigo Kumpera
Modified: 2017-02-06 23:20 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Rodrigo Kumpera 2017-02-02 17:57:27 UTC
From: https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=1845&host_id=142&revision_id=853580


[7:00:54] make[2]: *** No rule to make target `../../../mono/mcs/class/Mono.Data.Sqlite/Mono.Data.Sqlite_2.0/MonoPInvokeCallbackAttribute.cs', needed by `bin/Debug/Mono.Data.Sqlite.dll'.  Stop.
[7:00:54] make[1]: *** [all-recurse] Error 1
Comment 1 Marek Safar 2017-02-03 11:51:46 UTC
Question is where to push the fix?
Comment 2 Jonathan Pryor 2017-02-04 02:34:49 UTC
Proposed fix: https://github.com/xamarin/xamarin-android/pull/418
Comment 3 Rodrigo Kumpera 2017-02-06 23:20:00 UTC
Closing it since the fix was merged. Thanks Jon!

Note You need to log in before you can comment on or make changes to this bug.