Bug 52157 - SocketTest.ConnectedProperty test fails in FullAOT Linux runs
Summary: SocketTest.ConnectedProperty test fails in FullAOT Linux runs
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Release
Assignee: Katelyn Gadd
URL:
Depends on:
Blocks:
 
Reported: 2017-01-31 19:38 UTC by Alexander Köplinger [MSFT]
Modified: 2017-07-10 12:55 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alexander Köplinger [MSFT] 2017-01-31 19:38:03 UTC
E.g. https://jenkins.mono-project.com/job/test-mono-mainline-fullaot/label=ubuntu-1404-amd64/204/testReport/(root)/SocketTest/ConnectedProperty/

> MESSAGE:
> Expected: True
> But was:  False
> 
> +++++++++++++++++++
> STACK TRACE:
> at MonoTests.System.Net.Sockets.SocketTest.ConnectedProperty () [0x0008e] in > /mnt/jenkins/workspace/test-mono-mainline-fullaot/label/ubuntu-1404-amd64/mcs/class/System/Test/System.Net.Sockets/SocketTest.> cs:3740 
>   at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],> System.Exception&)
>   at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder > binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <f9e0bffa2f45445f835e8dedff81efb2>:0 

It was disabled on Mac a while ago: https://github.com/mono/mono/commit/7c32f15193c4d7699537cc604f3056217bbbbf5a
(probably due to https://bugzilla.xamarin.com/show_bug.cgi?id=5495)

Original Novell bug: https://bugzilla.novell.com/show_bug.cgi?id=443346
Original fix: https://github.com/mono/mono/commit/c25ee5d95b7531d4ee395b8671320df9b7c81816
Original test: https://github.com/mono/mono/commit/0b00587d8a0a88fe557fb9bcbffbdaa1f2cdeb7b

The weird thing is that it passes on non-FullAOT Linux runs, logically it should fail there too.
Comment 1 Ludovic Henry 2017-02-08 21:49:35 UTC
This only fails with full aot, and not without it. Reassigning to Alexander.
Comment 2 Katelyn Gadd 2017-07-10 12:55:06 UTC
Fixed by merge of https://github.com/mono/mono/pull/5153