Bug 51929 - [Xamarin-Profiler]:Accessibility: MAS36 : Windows: Keyboard:Table header items are not accessible under "Instrument Detail Area" section.
Summary: [Xamarin-Profiler]:Accessibility: MAS36 : Windows: Keyboard:Table header item...
Status: CLOSED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Windows (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: 15.6
Assignee: Sergiy Velychko (Global Logic)
URL:
Depends on:
Blocks:
 
Reported: 2017-01-28 11:54 UTC by Dona Venkata Jaswanth Kumpatla
Modified: 2018-04-23 12:29 UTC (History)
7 users (show)

Tags: wipro, xamarin-profiler, a11ymas, mas36, accessibility
Is this bug a regression?: ---
Last known good build:


Attachments
Please find the attached screenshot (223.96 KB, application/x-zip-compressed)
2017-01-28 11:54 UTC, Dona Venkata Jaswanth Kumpatla
Details
Fixed_51929 (129.39 KB, image/png)
2018-04-23 12:29 UTC, Ramya Sri Narasinga
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Dona Venkata Jaswanth Kumpatla 2017-01-28 11:54:49 UTC
Created attachment 19611 [details]
Please find the attached screenshot

Testing Environment:

OS: 
      •	Windows 10.
      •	Version 1067.
      •	Build 14393.607.
Visual Studio and Xamarin:
      •	VS 2017 RC Enterprise.
      •	Xamarin For VS 4.3.0.550.
      •	Xamarin Profiler 1.0.4
Pre -Requisites: Build and Deploy Xamarin Application into Android Emulator

Repro:
1.Launch Xamarin profiler through Visual Studio.
2.From "Choose an Instrument Template" window navigate to the "General" tab and select any instruments tab from the existing "Available Instruments”.
3.select any tab from the “Instrument Detail Area" section and navigate to the header items of the table after the "search edit box".

Note:
The issue is observed for all the selected instruments in "Instrument Detail Area" section which contains table with header elements below the "Instruments" List.

Actual Result:
In "Instrument Detail Area" section after the "search edit box" the table header items are not accessible.

Expected Result: 
The table header items should accessible.
Observation:
User will miss the ascending and descending order buttons for each column for the header items.

User Impact:
Users with visual and/or motor impairments who rely on keyboard may find it difficult while navigating with the tab to use the Application.
Comment 1 Luis Aguilera 2017-06-22 12:54:04 UTC
moving to 15.4
Comment 2 xamarin-release-manager 2017-10-09 11:33:54 UTC
Fixed in version 1.6.1.84 (master)

Author: Sergiy Velychko
Commit: deca9b4a5048cee6c80e79296af4209dfe68f6a4 (xamarin/profiler)
Comment 3 Ramya Sri Narasinga 2018-04-23 12:29:05 UTC
Created attachment 26270 [details]
Fixed_51929

The bug fix verified on Xamarin Profiler version: 1.6.2.145, hence closing this bug.